meta-wayland/recipes-wlroots/gamescope/gamescope/0001-meson.build-dont-leak-buildpath.patch
2024-02-29 14:21:38 +01:00

29 lines
781 B
Diff

From 2c97df6e0940c4b0a9ce30f7c422c579cf44c60c Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Mon, 12 Feb 2024 16:15:33 +0100
Subject: [PATCH] meson.build: dont leak buildpath
This fixes buildpath in gamescope binary
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 04bd472..345a2a7 100644
--- a/meson.build
+++ b/meson.build
@@ -67,7 +67,7 @@ add_project_arguments(
if hwdata_dep.found()
add_project_arguments(
- '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('pkgdatadir') / 'pnp.ids'),
+ '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('datadir') / 'hwdata' / 'pnp.ids'),
language: 'cpp',
)
else
--
2.43.0