gamescope: update

This commit is contained in:
Markus Volk 2024-02-29 14:12:48 +01:00
parent 3797afa77e
commit 9e945a0d79
3 changed files with 17 additions and 18 deletions

View File

@ -10,16 +10,16 @@ manually add it to CXXFLAGS
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/meson.build b/src/meson.build
index 4f88d6e..c3ad9c8 100644
index 7f7e793..c61077f 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -20,7 +20,7 @@ cap_dep = dependency('libcap', required: false)
@@ -20,7 +20,7 @@ cap_dep = dependency('libcap', required: get_option('rt_cap'))
epoll_dep = dependency('epoll-shim', required: false)
glm_dep = dependency('glm')
sdl_dep = dependency('SDL2')
sdl_dep = dependency('SDL2', required: get_option('sdl2_backend'))
-stb_dep = dependency('stb')
+stb_dep = dependency('stb', required: false)
avif_dep = dependency('libavif', version: '>=1.0.0')
avif_dep = dependency('libavif', version: '>=1.0.0', required: get_option('avif_screenshots'))
wlroots_dep = dependency(
--

View File

@ -11,18 +11,18 @@ Signed-off-by: Markus Volk <f_l_k@t-online.de>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 7af6884..4fb8650 100644
index 04bd472..345a2a7 100644
--- a/meson.build
+++ b/meson.build
@@ -62,7 +62,7 @@ endif
add_project_arguments(
'-DHAVE_PIPEWIRE=@0@'.format(pipewire_dep.found().to_int()),
'-DHAVE_OPENVR=@0@'.format(openvr_dep.found().to_int()),
@@ -67,7 +67,7 @@ add_project_arguments(
if hwdata_dep.found()
add_project_arguments(
- '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('pkgdatadir') / 'pnp.ids'),
+ '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('datadir') / 'hwdata' / 'pnp.ids'),
language: 'cpp',
)
)
else
--
2.43.0

View File

@ -10,11 +10,8 @@ DEPENDS += " \
glm \
glslang-native \
hwdata \
libavif \
libcap \
libdisplay-info \
libliftoff \
libsdl2 \
libdrm \
libx11\
libxcomposite \
@ -36,11 +33,13 @@ RDEPENDS:${PN} = "xwayland hwdata"
CXXFLAGS:append = " -I${STAGING_INCDIR}/stb"
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl pipewire', d)} openvr"
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl pipewire', d)} rt_cap avif_screenshots openvr"
PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=false"
PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
PACKAGECONFIG[opengl] = ",,mesa-glut"
PACKAGECONFIG[avif_screenshots] = "-Davif_screenshots=enabled,-Davif_screenshots=disabled,libavif"
PACKAGECONFIG[rt_cap] = "-Drt_cap=enabled,-Drt_cap=disabled,libcap"
PACKAGECONFIG[sdl2_backend] = "-Dsdl2_backend=enabled,-Dsdl2_backend=disabled,libsdl2"
SRC_URI = " \
gitsm://github.com/ValveSoftware/gamescope.git;branch=master;protocol=https \
@ -48,8 +47,8 @@ SRC_URI = " \
file://0001-meson.build-dont-leak-buildpath.patch \
file://0001-meson.build-dont-force-subprojects.patch\
"
SRCREV = "bca7990e61a1eb8198e54d86a4a9a44d41d9b07e"
PV = "3.14.0"
SRCREV = "d0d23c4c3010c81add1bd90cbe478ce4a386e28d"
PV = "3.14.2"
S = "${WORKDIR}/git"