hyprland: Update

This commit is contained in:
Markus Volk 2023-10-17 10:32:12 +02:00
parent 7177018b96
commit e5b969dac9
2 changed files with 22 additions and 22 deletions

View File

@ -1,23 +1,21 @@
From 19e0c04a57bfb3677caf1ac8c22527b066666a95 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Sun, 23 Jul 2023 10:19:54 +0200
Subject: [PATCH] hyprland: update
---
meson.build | 17 +----------------
src/meson.build | 6 +++---
2 files changed, 4 insertions(+), 19 deletions(-)
diff --git a/meson.build b/meson.build
index f3802553..6a924a79 100644
index 1d2c7f9f..c5ef4e67 100644
--- a/meson.build
+++ b/meson.build
@@ -21,9 +21,9 @@ else
@@ -33,20 +33,7 @@ if cpp_compiler.check_header('execinfo.h')
add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
endif
GIT_BRANCH = run_command('git', 'rev-parse', '--abbrev-ref', 'HEAD', check: false).stdout().strip()
-GIT_COMMIT_HASH = run_command('git', 'rev-parse', 'HEAD', check: false).stdout().strip()
+GIT_COMMIT_HASH = '@GIT_COMMIT_HASH@'
GIT_COMMIT_MESSAGE = run_command('sh', '-c', 'git show | head -n 5 | tail -n 1', check: false).stdout().strip()
-GIT_DIRTY = run_command('sh', '-c', 'git diff-index --quiet HEAD -- || echo "dirty"', check: false).stdout().strip()
+GIT_DIRTY = '@GIT_DIRTY@'
add_project_arguments(
[
@@ -39,21 +39,8 @@ add_project_arguments(
],
language: 'cpp')
-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
-have_xwlr = wlroots.get_variable('features').get('xwayland')
-xcb_dep = dependency('xcb', required: get_option('xwayland'))
@ -32,17 +30,15 @@ index f3802553..6a924a79 100644
-have_xwayland = xcb_dep.found() and have_xwlr
-
-if not have_xwayland
- add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
+if get_option('xwayland').disabled()
+ add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif
backtrace_dep = cpp_compiler.find_library('execinfo', required: false)
diff --git a/src/meson.build b/src/meson.build
index 7b658d31..60aa4057 100644
index 0af864b9..38723b8c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -7,16 +7,16 @@ executable('Hyprland', src,
@@ -9,16 +9,16 @@ executable('Hyprland', src,
server_protos,
dependency('wayland-server'),
dependency('wayland-client'),

View File

@ -38,8 +38,8 @@ SRC_URI = " \
file://meson-build.patch \
"
SRCREV = "1b48642fd15c433c53876f1b933dcd46265caf8f"
PV = "0.30.0"
SRCREV = "5b8cfdf2efc44106b61e60c642fd964823fd89f3"
PV = "0.31.0"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check
@ -51,3 +51,7 @@ PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,libxcb xcb-uti
PACKAGECONFIG[vulkan] = ",,vulkan-loader vulkan-headers glslang-native"
FILES:${PN} += "${datadir}"
do_install:append() {
install -m 0644 ${S}/src/version.h ${D}${includedir}/hyprland/src
}