mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-19 20:08:27 +01:00
phosh: update
This commit is contained in:
parent
4c91ae8b81
commit
e0a79f28f6
@ -0,0 +1,36 @@
|
||||
From bfd49ad17c115899bdec41f5819fef21f622e620 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Thu, 6 Jun 2024 21:21:19 +0200
|
||||
Subject: [PATCH] meson.build: dont read includedir from pkg-config
|
||||
|
||||
This sets includedir to /usr/include which is inappropriate for cross-compiling.
|
||||
---
|
||||
src/meson.build | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index f9107b26..8bddeace 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -343,12 +343,12 @@ libphosh_sources = files(
|
||||
]
|
||||
|
||||
# See https://gitlab.gnome.org/GNOME/libsoup/-/merge_requests/394
|
||||
-if libsoup_dep.version().version_compare('< 3.5.1')
|
||||
- libsoup_dep = declare_dependency (
|
||||
- include_directories: libsoup_dep.get_variable(pkgconfig: 'includedir') / 'libsoup-3.0',
|
||||
- dependencies: cc.find_library('soup-3.0', required: true),
|
||||
- )
|
||||
-endif
|
||||
+#if libsoup_dep.version().version_compare('< 3.5.1')
|
||||
+# libsoup_dep = declare_dependency (
|
||||
+# include_directories: libsoup_dep.get_variable(pkgconfig: 'includedir') / 'libsoup-3.0',
|
||||
+# dependencies: cc.find_library('soup-3.0', required: true),
|
||||
+# )
|
||||
+#endif
|
||||
|
||||
phosh_deps = [
|
||||
libsoup_dep,
|
||||
--
|
||||
2.45.1
|
||||
|
@ -11,18 +11,18 @@ DEPENDS = " \
|
||||
evince \
|
||||
feedbackd \
|
||||
fribidi \
|
||||
gcr \
|
||||
glib-2.0 \
|
||||
gmobile \
|
||||
gnome-desktop \
|
||||
gtk+3 \
|
||||
gtk4 \
|
||||
libadwaita \
|
||||
gcr3 \
|
||||
libgudev \
|
||||
libhandy \
|
||||
libsecret \
|
||||
networkmanager \
|
||||
polkit \
|
||||
pulseaudio \
|
||||
libsoup-3.0 \
|
||||
upower \
|
||||
wayland \
|
||||
wayland-native \
|
||||
@ -52,17 +52,14 @@ inherit features_check gsettings meson pkgconfig gtk-icon-cache
|
||||
|
||||
SRC_URI = " \
|
||||
gitsm://gitlab.gnome.org/World/Phosh/phosh.git;protocol=https;nobranch=1 \
|
||||
file://0001-meson.build-dont-read-includedir-from-pkg-config.patch \
|
||||
"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
PV = "0.36.0"
|
||||
SRCREV = "62a4ba9d8a38750a49ae6187f3497c54a030be45"
|
||||
PV = "0.39.0"
|
||||
SRCREV = "e1e263efc239870e81c2e4d013bf0615f260141f"
|
||||
|
||||
EXTRA_OEMESON += "--buildtype=release"
|
||||
|
||||
do_install:append() {
|
||||
install -Dm 644 ${WORKDIR}/phosh.pam ${D}${sysconfdir}/pam.d/phosh
|
||||
}
|
||||
|
||||
FILES:${PN} += "${datadir} ${libdir}"
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user