mako: update

This commit is contained in:
Markus Volk 2022-10-23 13:44:54 +02:00
parent d634877e31
commit c6db56e20e
2 changed files with 2 additions and 31 deletions

View File

@ -1,28 +0,0 @@
From e7973e352b8649b10053f3feb82134d9cefb851e Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Tue, 17 May 2022 19:00:02 +0200
Subject: [PATCH] meson.build: make epoll-shim dependency optional
After updating my host system, meson.build tries to depend on the epoll-shim.
Since we are not on BSD, we dont have it and it is not needed. Make the
dependency on it optional.
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 84abdcb..9687b23 100644
--- a/meson.build
+++ b/meson.build
@@ -35,7 +35,7 @@ wayland_cursor = dependency('wayland-cursor')
epoll = dependency('', required: false)
if (not cc.has_function('timerfd_create', prefix: '#include <sys/timerfd.h>') or
not cc.has_function('signalfd', prefix: '#include <sys/signalfd.h>'))
- epoll = dependency('epoll-shim')
+ epoll = dependency('epoll-shim', required: false)
endif
if get_option('sd-bus-provider') == 'auto'
--
2.25.1

View File

@ -9,7 +9,6 @@ REQUIRED_DISTRO_FEATURES = "wayland"
SRC_URI = " \
git://github.com/emersion/mako.git;protocol=https;branch=master \
file://0001-meson.build-make-epoll-shim-dependency-optional.patch \
"
DEPENDS = " \
@ -40,8 +39,8 @@ PACKAGECONFIG ?= " \
"
S = "${WORKDIR}/git"
PV = "1.6"
SRCREV = "ddc1849804c8703ec749140e3a55febb5250e934"
PV = "1.7.1"
SRCREV = "51ad133d3e9ebca27e7af25f86dcbf67b7f25f11"
EXTRA_OEMESON += "--buildtype release"