gtk-layer-shell: dont use hosts wayland-scanner

This commit is contained in:
Markus Volk 2022-07-09 01:23:54 +02:00
parent b4d9336ddd
commit a6b9e2778c
2 changed files with 29 additions and 2 deletions

View File

@ -0,0 +1,23 @@
From 25e9ac8ce8aba85f0c4e3c643d517fecc6e2fd96 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Sat, 9 Jul 2022 01:08:21 +0200
Subject: [PATCH] protocol/meson.build: dont use pkgconfig for wayland-scanner
wayland-scanner path gets read from target waylands .pc file. Avoid it
---
protocol/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/protocol/meson.build b/protocol/meson.build
index 2ce0e0c..12f389f 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -1,4 +1,4 @@
-if wayland_scanner.found()
+if false
prog_wayland_scanner = find_program(wayland_scanner.get_pkgconfig_variable('wayland_scanner'))
else
prog_wayland_scanner = find_program('wayland-scanner')
--
2.25.1

View File

@ -12,9 +12,13 @@ DEPENDS += " \
gtk+3 \
wayland \
wayland-native \
wayland-protocols \
"
SRC_URI = "git://github.com/wmww/gtk-layer-shell.git;protocol=https;branch=master"
SRC_URI = " \
git://github.com/wmww/gtk-layer-shell.git;protocol=https;branch=master \
file://0001-protocol-meson.build-dont-use-pkgconfig-for-wayland-.patch \
"
S = "${WORKDIR}/git"
PV = "0.7.0"
@ -22,7 +26,7 @@ SRCREV = "ca37ef1baa623302dda5fcea200d04e0d9a10578"
inherit meson pkgconfig features_check gobject-introspection vala
EXTRA_OEMESON += "--buildtype release -Dvapi=true"
EXTRA_OEMESON += "--buildtype release"
FILES:${PN} = "${datadir} ${libdir}"