mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2025-02-13 07:32:46 +01:00
gamescope: update 3.13.16 -> 3.14.0
- fix buildpath leakage into gamescope binary
This commit is contained in:
parent
f1079fc031
commit
724b95019f
@ -10,18 +10,18 @@ manually add it to CXXFLAGS
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index 5385dfb..f912cfc 100644
|
||||
index 4f88d6e..c3ad9c8 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -19,7 +19,7 @@ cap_dep = dependency('libcap', required: false)
|
||||
@@ -20,7 +20,7 @@ cap_dep = dependency('libcap', required: false)
|
||||
epoll_dep = dependency('epoll-shim', required: false)
|
||||
glm_dep = dependency('glm')
|
||||
sdl_dep = dependency('SDL2')
|
||||
-stb_dep = dependency('stb')
|
||||
+stb_dep = dependency('stb', required: false)
|
||||
avif_dep = dependency('libavif', version: '>=1.0.0')
|
||||
|
||||
wlroots_dep = dependency(
|
||||
'wlroots',
|
||||
--
|
||||
2.43.0
|
||||
|
||||
|
@ -0,0 +1,28 @@
|
||||
From 2c97df6e0940c4b0a9ce30f7c422c579cf44c60c Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Mon, 12 Feb 2024 16:15:33 +0100
|
||||
Subject: [PATCH] meson.build: dont leak buildpath
|
||||
|
||||
This fixes buildpath in gamescope binary
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 7af6884..4fb8650 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -62,7 +62,7 @@ endif
|
||||
add_project_arguments(
|
||||
'-DHAVE_PIPEWIRE=@0@'.format(pipewire_dep.found().to_int()),
|
||||
'-DHAVE_OPENVR=@0@'.format(openvr_dep.found().to_int()),
|
||||
- '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('pkgdatadir') / 'pnp.ids'),
|
||||
+ '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('datadir') / 'hwdata' / 'pnp.ids'),
|
||||
language: 'cpp',
|
||||
)
|
||||
|
||||
--
|
||||
2.43.0
|
||||
|
@ -15,7 +15,6 @@ DEPENDS += " \
|
||||
libdisplay-info \
|
||||
libliftoff \
|
||||
libsdl2 \
|
||||
stb \
|
||||
libx11\
|
||||
libxcomposite \
|
||||
libxcursor \
|
||||
@ -24,6 +23,7 @@ DEPENDS += " \
|
||||
libxmu \
|
||||
libxrender \
|
||||
libxtst \
|
||||
stb \
|
||||
vulkan-headers \
|
||||
wayland \
|
||||
wayland-native \
|
||||
@ -31,6 +31,8 @@ DEPENDS += " \
|
||||
wlroots-0.17 \
|
||||
"
|
||||
|
||||
RDEPENDS:${PN} = "xwayland"
|
||||
|
||||
CXXFLAGS:append = " -I${STAGING_INCDIR}/stb"
|
||||
|
||||
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl pipewire', d)}"
|
||||
@ -38,12 +40,14 @@ PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=fa
|
||||
PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
|
||||
PACKAGECONFIG[opengl] = ",,mesa-glut"
|
||||
|
||||
|
||||
SRC_URI = " \
|
||||
gitsm://github.com/ValveSoftware/gamescope.git;branch=master;protocol=https \
|
||||
file://0001-meson.build-dont-fail-if-stb-is-not-found.patch \
|
||||
file://0001-meson.build-dont-leak-buildpath.patch \
|
||||
"
|
||||
SRCREV = "3e14ef9c37266b19ba77fbef467d1b8a77d827f2"
|
||||
PV = "3.13.19"
|
||||
SRCREV = "bca7990e61a1eb8198e54d86a4a9a44d41d9b07e"
|
||||
PV = "3.14.0"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user