wlroots: update; add recipe for 0.16

This commit is contained in:
Markus Volk 2022-12-06 18:45:23 +01:00
parent f845a29f63
commit 6064375ae6
4 changed files with 90 additions and 12 deletions

View File

@ -0,0 +1,26 @@
From 1a7c0aeadd27eaa5454d40fd6415ab4d0afecb94 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Fri, 11 Nov 2022 03:25:19 +0100
Subject: [PATCH] backend/drm/meson.build: dont use native hwdata
hwdata is allarch, there's no need to build a native package.
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Upstream-Status: inappropriate (oe specific) [https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/3844]
---
backend/drm/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/backend/drm/meson.build b/backend/drm/meson.build
index 7bde50c25..8aa404c4b 100644
--- a/backend/drm/meson.build
+++ b/backend/drm/meson.build
@@ -1,4 +1,4 @@
-hwdata = dependency('hwdata', required: false, native: true)
+hwdata = dependency('hwdata', required: false)
if hwdata.found()
hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
pnp_ids = files(hwdata_dir / 'pnp.ids')
--
2.34.1

View File

@ -1,22 +1,22 @@
From 1a7c0aeadd27eaa5454d40fd6415ab4d0afecb94 Mon Sep 17 00:00:00 2001
From 55c9c3ac4c1eb645476a725fbab1d9046cbacb16 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Fri, 11 Nov 2022 03:25:19 +0100
Subject: [PATCH] backend/drm/meson.build: dont use native hwdata
hwdata is allarch, there's no need to build a native package.
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Date: Tue, 6 Dec 2022 16:18:41 +0100
Subject: [PATCH] meson.build: dont use native hwdata
Upstream-Status: inappropriate (oe specific) [https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/3844]
---
backend/drm/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/backend/drm/meson.build b/backend/drm/meson.build
index 7bde50c25..8aa404c4b 100644
index fc4d84d6f..b01818901 100644
--- a/backend/drm/meson.build
+++ b/backend/drm/meson.build
@@ -1,4 +1,4 @@
@@ -2,7 +2,7 @@ if not features['session']
subdir_done()
endif
-hwdata = dependency('hwdata', required: false, native: true)
+hwdata = dependency('hwdata', required: false)
if hwdata.found()

View File

@ -0,0 +1,52 @@
SUMMARY = "A modular Wayland compositor library"
DESCRIPTION = "Pluggable, composable, unopinionated modules for building a \
Wayland compositor; or about 50,000 lines of code you were \
going to write anyway."
HOMEPAGE = "https://gitlab.freedesktop.org/wlroots"
BUGTRACKER = "https://gitlab.freedesktop.org/wlroots/wlroots/-/issues"
SECTION = "graphics"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7578fad101710ea2d289ff5411f1b818"
REQUIRED_DISTRO_FEATURES = "wayland"
DEPENDS += " \
hwdata \
libdrm \
libxkbcommon \
pixman \
seatd \
wayland \
wayland-native \
wayland-protocols \
"
PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false,libpng ffmpeg"
PACKAGECONFIG[opengl] = ",,virtual/egl virtual/libgles2"
PACKAGECONFIG[gbm] = ",,virtual/libgbm"
PACKAGECONFIG[libinput] = ",,libinput"
PACKAGECONFIG[systemd] = ",,systemd"
PACKAGECONFIG[sysvinit] = ",,eudev elogind"
PACKAGECONFIG[vulkan] = ",,vulkan-loader vulkan-headers glslang-native"
PACKAGECONFIG[x11] = ",,xcb-util-renderutil"
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,xwayland xcb-util-wm"
PACKAGECONFIG ?= " \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd sysvinit vulkan x11 xwayland opengl', d)} \
libinput \
"
SRC_URI = " \
git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=master;protocol=https \
file://0001-backend-drm-meson.build-dont-use-native-hwdata-0.16.patch \
"
SRCREV = "1712a7d27444d62f8da8eeedf0840b386a810e96"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check
EXTRA_OEMESON += "--buildtype release"
BBCLASSEXTEND = ""

View File

@ -30,7 +30,7 @@ PACKAGECONFIG[systemd] = ",,systemd"
PACKAGECONFIG[sysvinit] = ",,eudev elogind"
PACKAGECONFIG[vulkan] = ",,vulkan-loader vulkan-headers glslang-native"
PACKAGECONFIG[x11] = ",,xcb-util-renderutil"
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,xwayland xcb-util-wm,xwayland"
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,xwayland xcb-util-wm"
PACKAGECONFIG ?= " \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd sysvinit vulkan x11 xwayland opengl', d)} \
@ -41,8 +41,8 @@ SRC_URI = " \
git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=master;protocol=https \
file://0001-backend-drm-meson.build-dont-use-native-hwdata.patch \
"
SRCREV = "77d9fc08483fd516e1540fdbfaf9ee789772a778"
PV = "0.16.0"
SRCREV = "1bd0ba3949605c1fe382bbdb62b8a9aa2e462573"
PV = "0.17.0-dev"
S = "${WORKDIR}/git"