hyprwall/main.rs: adjust application_id

This fixes 'icon not shown' in applications that rely on proper
application_id naming (e.g. nwg-dock-hyprland)
This commit is contained in:
Markus Volk 2024-10-28 22:47:15 +01:00
parent 8b16d3622f
commit 600c17c2e7
2 changed files with 30 additions and 0 deletions

View File

@ -0,0 +1,29 @@
From 61aa245a0c4a2bffa498138139b822c227a91a34 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Mon, 28 Oct 2024 22:26:20 +0100
Subject: [PATCH] main.rs: adjust application_id
This fixes icon not shown in applications that rely on proper application_id
naming (e.g. nwg-dock-hyprland)
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
src/main.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/main.rs b/src/main.rs
index 9bc13ce..4d39674 100644
--- a/src/main.rs
+++ b/src/main.rs
@@ -151,7 +151,7 @@ along with this program; if not, see
}
let app = Application::builder()
- .application_id("nnyyxxxx.hyprwall")
+ .application_id("hyprwall")
.build();
app.connect_activate(gui::build_ui);
--
2.47.0

View File

@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRC_URI += "git://github.com/nnyyxxxx/hyprwall.git;protocol=https;nobranch=1;branch=main"
SRC_URI += "file://0001-Cargo.toml-set-panic-to-unwind-dont-strip.patch"
SRC_URI += "file://0001-main.rs-adjust-application_id.patch"
SRCREV = "65773367eac77d1e122a607ca64008841f70ddc7"
S = "${WORKDIR}/git"
PV = "0.1.6"