mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-19 20:08:27 +01:00
wlroots-0.17: update
This commit is contained in:
parent
edc74c457a
commit
5a2220b97c
@ -39,9 +39,8 @@ PACKAGECONFIG ?= " \
|
||||
"
|
||||
|
||||
SRC_URI = "git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=0.17;protocol=https"
|
||||
SRC_URI += "file://backend-drm-add-support-for-libliftoff-v0.5.0.patch"
|
||||
SRCREV = "bc73e507abd1e8319353a8601f1f8ebfe17307ee"
|
||||
PV = "0.17.3"
|
||||
SRCREV = "a2d2c38a3127745629293066beeed0a649dff8de"
|
||||
PV = "0.17.4"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 8b1628adcf530fd5396f62479175e486126efc7c Mon Sep 17 00:00:00 2001
|
||||
From: Simon Ser <contact@emersion.fr>
|
||||
Date: Tue, 28 May 2024 00:30:33 +0200
|
||||
Subject: [PATCH] backend/drm: add support for libliftoff v0.5.0
|
||||
|
||||
Don't require libliftoff 0.5.0 just yet: we want to be able to
|
||||
backport this patch.
|
||||
---
|
||||
backend/drm/libliftoff.c | 5 +++++
|
||||
backend/drm/meson.build | 1 +
|
||||
2 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/backend/drm/libliftoff.c b/backend/drm/libliftoff.c
|
||||
index a3b61540..12dd8fdb 100644
|
||||
--- a/backend/drm/libliftoff.c
|
||||
+++ b/backend/drm/libliftoff.c
|
||||
@@ -7,6 +7,7 @@
|
||||
|
||||
#include "backend/drm/drm.h"
|
||||
#include "backend/drm/iface.h"
|
||||
+#include "config.h"
|
||||
|
||||
static bool init(struct wlr_drm_backend *drm) {
|
||||
// TODO: lower log level
|
||||
@@ -436,7 +437,11 @@ static bool crtc_commit(struct wlr_drm_connector *conn,
|
||||
goto out;
|
||||
}
|
||||
|
||||
+#if HAVE_LIBLIFTOFF_0_5
|
||||
+ int ret = liftoff_output_apply(crtc->liftoff, req, flags, NULL);
|
||||
+#else
|
||||
int ret = liftoff_output_apply(crtc->liftoff, req, flags);
|
||||
+#endif
|
||||
if (ret != 0) {
|
||||
wlr_drm_conn_log(conn, test_only ? WLR_DEBUG : WLR_ERROR,
|
||||
"liftoff_output_apply failed: %s", strerror(-ret));
|
||||
diff --git a/backend/drm/meson.build b/backend/drm/meson.build
|
||||
index 5d2f2b1f8c..7c00b0f085 100644
|
||||
--- a/backend/drm/meson.build
|
||||
+++ b/backend/drm/meson.build
|
||||
@@ -48,6 +48,7 @@ wlr_files += files(
|
||||
|
||||
if libliftoff.found()
|
||||
wlr_files += files('libliftoff.c')
|
||||
+ internal_config.set10('HAVE_LIBLIFTOFF_0_5', libliftoff.version().version_compare('>=0.5.0'))
|
||||
endif
|
||||
|
||||
features += { 'drm-backend': true }
|
||||
--
|
||||
GitLab
|
||||
|
Loading…
Reference in New Issue
Block a user