wayfire: fix build

This commit is contained in:
Markus Volk 2022-02-15 02:30:36 +01:00
parent 042b2c169e
commit 492fc39ef1
8 changed files with 160 additions and 11 deletions

View File

@ -0,0 +1,35 @@
From b8ba62e91d30ede97478f66587300525c5d7bd7e Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Tue, 15 Feb 2022 01:40:30 +0100
Subject: [PATCH] meson.build: build with system wf-touch and wf-utils
---
meson.build | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
index ab3652a8..a9f287e2 100644
--- a/meson.build
+++ b/meson.build
@@ -32,6 +32,8 @@ threads = dependency('threads')
xkbcommon = dependency('xkbcommon')
wlroots = dependency('wlroots', version: ['>=0.15.0', '<0.16.0'], required: get_option('use_system_wlroots'))
wfconfig = dependency('wf-config', version: ['>=0.7.0', '<0.8.0'], required: get_option('use_system_wfconfig'))
+wfutils = dependency('wf-utils', version: '>=0.4.0')
+wftouch = dependency('wf-touch')
use_system_wlroots = not get_option('use_system_wlroots').disabled() and wlroots.found()
if not use_system_wlroots
@@ -43,9 +45,6 @@ if not use_system_wfconfig
wfconfig = subproject('wf-config').get_variable('wfconfig')
endif
-wfutils = subproject('wf-utils').get_variable('wfutils')
-wftouch = subproject('wf-touch').get_variable('wftouch')
-
needs_libinotify = ['freebsd', 'dragonfly'].contains(host_machine.system())
libinotify = dependency('libinotify', required: needs_libinotify)
--
2.25.1

View File

@ -20,17 +20,22 @@ DEPENDS += " \
libxkbcommon \
libxml2 \
mesa \
pango \
pixman \
seatd \
wayland \
wayland-native \
wayland-protocols \
wf-config \
wf-utils \
wf-touch \
"
RRECOMMENDS:${PN} += " \
wlroots \
wcm \
wf-config \
wf-touch \
wf-utils \
wf-recorder \
wf-shell \
"
@ -41,12 +46,17 @@ PACKAGECONFIG[use_system_wlroots] = "-Duse_system_wlroots=enabled,-Duse_system_w
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled"
PACKAGECONFIG ?= " \
gles32 \
use_system_wfconfig \
use_system_wlroots \
"
SRC_URI = "git://github.com/WayfireWM/wayfire.git;protocol=https;branch=0.7.x"
SRCREV = "9458f58959512222f3f154b40b0a48584033ca24"
SRC_URI = " \
git://github.com/WayfireWM/wayfire.git;protocol=https;branch=0.7.x \
file://0001-meson.build-build-with-system-wf-touch-and-wf-utils.patch \
"
SRCREV = "835a7bf9bde4e78796f9fd9f14021476084a9728"
PV = "0.7.2"
S = "${WORKDIR}/git"
@ -54,5 +64,7 @@ inherit meson pkgconfig features_check
EXTRA_OEMESON += "--buildtype release"
FILES:${PN} += "${datadir}"
BBCLASSEXTEND = ""

View File

@ -14,9 +14,9 @@ DEPENDS = " \
REQUIRED_DISTRO_FEATURES = "wayland"
SRC_URI = "git://github.com/WayfireWM/wf-config.git;protocol=https;branch=master"
SRCREV = "e42a3870fb194842a505ad5a9671be1aebda0b0b"
PV = "0.8.0"
SRC_URI = "git://github.com/WayfireWM/wf-config.git;protocol=https;branch=0.7.x"
SRCREV = "62e3897f207f49b1a3bbb85ba4b11d9fea239ec1"
PV = "0.7.1"
S = "${WORKDIR}/git"
@ -24,6 +24,5 @@ inherit meson pkgconfig features_check
EXTRA_OEMESON += "--buildtype release"
BBCLASSEXTEND = ""

View File

@ -12,14 +12,13 @@ DEPENDS = " \
wayland-protocols \
wayfire \
gtkmm3 \
gtk-layer-shell \
wf-config \
pulseaudio \
libnotify3 \
"
DEPENDS:append:class-target = " gobject-introspection-native qemu-native prelink-native"
REQUIRED_DISTRO_FEATURES = "wayland gobject-introspection-data"
REQUIRED_DISTRO_FEATURES = "wayland"
SRC_URI = " \
https://github.com/WayfireWM/wf-shell/releases/download/v${PV}/wf-shell-${PV}.tar.xz \
@ -33,7 +32,7 @@ inherit meson pkgconfig features_check
EXTRA_OEMESON += "--buildtype release"
FILES:${PN} += "${prefix}"
FILES:${PN} += "${datadir}"
BBCLASSEXTEND = ""

View File

@ -0,0 +1,28 @@
From 78024c2654dab996d43f27aa3f3276360c357baa Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Tue, 15 Feb 2022 01:29:13 +0100
Subject: [PATCH] meson.build: create .pc file
---
meson.build | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/meson.build b/meson.build
index 33dbb59..bd4172d 100644
--- a/meson.build
+++ b/meson.build
@@ -21,3 +21,11 @@ doctest = dependency('doctest', required: get_option('tests'))
if doctest.found()
subdir('test')
endif
+
+pkgconfig = import('pkgconfig')
+pkgconfig.generate(
+ libraries: wftouch_lib,
+ version: meson.project_version(),
+ filebase: meson.project_name(),
+ name: meson.project_name(),
+ description: 'Touch library for Wayfire')
--
2.25.1

View File

@ -0,0 +1,27 @@
SUMMARY = "Touchscreen gesture library"
HOMEPAGE = "https://github.com/WayfireWM/wf-touch"
BUGTRACKER = "https://github.com/WayfireWM/wf-touch/issues"
SECTION = "graphics"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=a5edde5b0aa2298140a914608a192560"
DEPENDS = "glm"
REQUIRED_DISTRO_FEATURES = "wayland"
SRC_URI = " \
git://github.com/WayfireWM/wf-touch.git;branch=master;protocol=https \
file://0001-meson.build-create-.pc-file.patch \
"
SRCREV = "8974eb0f6a65464b63dd03b842795cb441fb6403"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check
EXTRA_OEMESON += "--buildtype release"
BBCLASSEXTEND = ""

View File

@ -0,0 +1,24 @@
From 3fcdc43e301b5f166619689caac4751b601faf08 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Tue, 15 Feb 2022 01:03:03 +0100
Subject: [PATCH] meson.build: add missing header
---
meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/meson.build b/meson.build
index 43b60e8..94c9f84 100644
--- a/meson.build
+++ b/meson.build
@@ -76,6 +76,7 @@ headers_parser = [
'wayfire/parser/action_parser.hpp',
'wayfire/parser/condition_parser.hpp',
'wayfire/parser/rule_parser.hpp',
+'wayfire/parser/lambda_rule_parser.hpp',
]
headers_rule = [
--
2.25.1

View File

@ -0,0 +1,25 @@
SUMMARY = "Contains utility classes for Wayfire"
HOMEPAGE = "https://github.com/WayfireWM/wf-utils"
BUGTRACKER = "https://github.com/WayfireWM/wf-utils/issues"
SECTION = "graphics"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a5edde5b0aa2298140a914608a192560"
REQUIRED_DISTRO_FEATURES = "wayland"
SRC_URI = " \
git://github.com/WayfireWM/wf-utils.git;branch=master;protocol=https \
file://0001-meson.build-add-missing-header.patch \
"
SRCREV = "889fdafa7b09fc6ce70313fd3f067cfc8c21a2ac"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check
EXTRA_OEMESON += "--buildtype release"
BBCLASSEXTEND = ""