mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-20 04:18:25 +01:00
clay: add recipe
This commit is contained in:
parent
1af2f8f513
commit
3e5f063772
@ -0,0 +1,40 @@
|
||||
From f14a8d54650f40ecb6f018fd7d5ac7cffbc9358f Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Sun, 7 Aug 2022 17:03:05 +0200
|
||||
Subject: [PATCH] meson.build: build with system wlroots
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
meson.build | 16 ++++++++--------
|
||||
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index dfcb0e1..42a90de 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -19,14 +19,14 @@ add_project_arguments(
|
||||
|
||||
cc = meson.get_compiler('c')
|
||||
|
||||
-wlroots_subproj = subproject(
|
||||
- 'wlroots',
|
||||
- default_options: ['examples=false', 'default_library=static'],
|
||||
- version: '>= 0.11.0',
|
||||
- required: true,
|
||||
-)
|
||||
-
|
||||
-wlroots = wlroots_subproj.get_variable('wlroots')
|
||||
+#wlroots_subproj = subproject(
|
||||
+# 'wlroots',
|
||||
+# default_options: ['examples=false', 'default_library=static'],
|
||||
+# version: '>= 0.11.0',
|
||||
+# required: true,
|
||||
+#)
|
||||
+
|
||||
+wlroots = dependency('wlroots', version: '>= 0.11.0')
|
||||
wayland_protos = dependency('wayland-protocols', version: '>=1.18')
|
||||
wayland_server = dependency('wayland-server')
|
||||
wayland_client = dependency('wayland-client')
|
||||
--
|
||||
2.34.1
|
||||
|
@ -0,0 +1,36 @@
|
||||
From 931b70e6575933f03202df639a2a72506f9b73ac Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Sun, 7 Aug 2022 16:56:39 +0200
|
||||
Subject: [PATCH] meson.build: add libinput dependency
|
||||
|
||||
this would fix:
|
||||
ld: clay.p/src_clay_input.c.o: undefined reference to symbol 'libinput_device_config_scroll_has_natural_scroll@@LIBINPUT_0.12.0'
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
meson.build | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index dfcb0e1..50ddf93 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -32,6 +32,7 @@ wayland_server = dependency('wayland-server')
|
||||
wayland_client = dependency('wayland-client')
|
||||
pixman = dependency('pixman-1')
|
||||
xkbcommon = dependency('xkbcommon')
|
||||
+libinput = dependency('libinput')
|
||||
math = cc.find_library('m')
|
||||
|
||||
wl_protocol_dir = wayland_protos.get_variable('pkgdatadir')
|
||||
@@ -101,6 +102,7 @@ executable(
|
||||
wlroots,
|
||||
xkbcommon,
|
||||
pixman,
|
||||
+ libinput,
|
||||
math,
|
||||
],
|
||||
install: true,
|
||||
--
|
||||
2.34.1
|
||||
|
29
recipes-wlroots/clay/clay_git.bb
Normal file
29
recipes-wlroots/clay/clay_git.bb
Normal file
@ -0,0 +1,29 @@
|
||||
|
||||
SUMMARY = "clay is a wayland compositor that does whatever I want my wayland compositor to do. Its features follows my mood."
|
||||
HOMEPAGE = "https://git.sr.ht/~kennylevinsen/clay"
|
||||
LICENSE = "MIT"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=715a99d2dd552e6188e74d4ed2914d5a"
|
||||
|
||||
DEPENDS = " \
|
||||
wayland-native \
|
||||
wayland \
|
||||
wayland-protocols \
|
||||
wlroots \
|
||||
pixman \
|
||||
libxkbcommon \
|
||||
libinput \
|
||||
"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
SRC_URI = " \
|
||||
gitsm://git.sr.ht/~kennylevinsen/clay;branch=master;protocol=https \
|
||||
file://0001-meson.build-build-with-system-wlroots.patch \
|
||||
file://0002-meson.build-add-libinput-dependency.patch \
|
||||
"
|
||||
|
||||
SRCREV = "74cdbeb68e5292ae9e718e81926109c1b0b42e94"
|
||||
S = "${WORKDIR}/git"
|
||||
|
Loading…
Reference in New Issue
Block a user