mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2025-04-01 22:55:56 +02:00
gimp: remove
recipe was added to meta-gnome
This commit is contained in:
parent
d59cfe31a5
commit
249ff357f9
@ -1,30 +0,0 @@
|
||||
From a7e40e19d17404cf5ec4135fc1becd5a90f5e1e1 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Wed, 25 Dec 2024 07:27:04 +0100
|
||||
Subject: [PATCH] gimp: cross-compile fix for bz2
|
||||
|
||||
autotools bzip2 build does not create pkgconfig files so looking for the dependency fails.
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
|
||||
Upstream-Status: Inappropriate [can probably be removed once bzip2 is built with meson or cmake]
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 4e48f8c64c..d5dce47015 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -765,7 +765,7 @@ zlib = dependency('zlib')
|
||||
MIMEtypes += 'image/x-psp'
|
||||
|
||||
# Compiler-provided headers can't be found in crossroads environment
|
||||
-if not meson.is_cross_build()
|
||||
+if true
|
||||
bz2 = cc.find_library('bz2')
|
||||
else
|
||||
bz2 = dependency('bzip2')
|
||||
--
|
||||
2.47.1
|
||||
|
@ -1,56 +0,0 @@
|
||||
From bf19c5687703769e406a8086036d4ed6421c33cb Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Mon, 13 Jan 2025 10:04:33 +0100
|
||||
Subject: [PATCH] meson.build: reproducibility fix
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
|
||||
Upstream-Status: Inappropriate [oe-specific]
|
||||
---
|
||||
meson.build | 28 ++++++++++++++--------------
|
||||
1 file changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 97cd621780..e47180db87 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1599,23 +1599,23 @@ conf.set('HAVE_FUNC_ATTRIBUTE_DESTRUCTOR',
|
||||
conf.set_quoted('CC', cc.get_id())
|
||||
|
||||
cc_version=''
|
||||
-if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
||||
- cc_cmd = run_command(cc, '-v', check: false)
|
||||
+#if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
||||
+# cc_cmd = run_command(cc, '-v', check: false)
|
||||
# Note: the call might actually fail when using ccache.
|
||||
# See: https://github.com/mesonbuild/meson/issues/6174
|
||||
- if cc_cmd.returncode() == 0
|
||||
- cc_version = cc_cmd.stdout() + cc_cmd.stderr()
|
||||
- endif
|
||||
-else
|
||||
+# if cc_cmd.returncode() == 0
|
||||
+# cc_version = cc_cmd.stdout() + cc_cmd.stderr()
|
||||
+# endif
|
||||
+#else
|
||||
# Various compilers have various options. Try most common ones. This
|
||||
# list of options comes from autotools checks.
|
||||
- foreach arg : [ '--version', '-v', '-V', '-qversion' ]
|
||||
- cc_cmd = run_command(cc, arg, check: false)
|
||||
- if cc_cmd.returncode() == 0
|
||||
- cc_version = cc_cmd.stdout()
|
||||
- endif
|
||||
- endforeach
|
||||
-endif
|
||||
+# foreach arg : [ '--version', '-v', '-V', '-qversion' ]
|
||||
+# cc_cmd = run_command(cc, arg, check: false)
|
||||
+# if cc_cmd.returncode() == 0
|
||||
+# cc_version = cc_cmd.stdout()
|
||||
+# endif
|
||||
+# endforeach
|
||||
+#endif
|
||||
if cc_version == ''
|
||||
# We didn't manage to get a meaningful verbose version from the
|
||||
# compiler. Just save its name and version.
|
||||
--
|
||||
2.47.1
|
||||
|
@ -1,131 +0,0 @@
|
||||
SUMMARY = "The GIMP is the GNU Image Manipulation Program"
|
||||
HOMEPAGE = "http://www.gimp.org"
|
||||
SECTION = "graphics"
|
||||
LICENSE = "GPL-3.0-only"
|
||||
LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
|
||||
|
||||
DEPENDS = " \
|
||||
appstream-glib \
|
||||
atk \
|
||||
babl \
|
||||
bzip2 \
|
||||
bison-native \
|
||||
cairo \
|
||||
fontconfig \
|
||||
freetype \
|
||||
gdk-pixbuf-native \
|
||||
gegl \
|
||||
gexiv2 \
|
||||
glib-2.0 \
|
||||
glib-2.0-native \
|
||||
gtk+3 \
|
||||
harfbuzz \
|
||||
iso-codes \
|
||||
jpeg \
|
||||
json-glib \
|
||||
lcms \
|
||||
libarchive \
|
||||
libexif \
|
||||
libmypaint \
|
||||
libpng \
|
||||
librsvg \
|
||||
librsvg-native \
|
||||
libxmu \
|
||||
libxslt-native \
|
||||
mypaint-brushes-1.0 \
|
||||
pango \
|
||||
poppler \
|
||||
poppler-data \
|
||||
python3-pygobject-native \
|
||||
tiff \
|
||||
xz \
|
||||
zlib \
|
||||
"
|
||||
|
||||
DEPENDS:append:libc-musl = " libexecinfo"
|
||||
|
||||
inherit meson gtk-icon-cache mime-xdg pkgconfig gettext gobject-introspection vala
|
||||
|
||||
GIR_MESON_OPTION = 'can-crosscompile-gir'
|
||||
VALA_MESON_OPTION = "vala"
|
||||
VALA_MESON_ENABLE_FLAG = "enabled"
|
||||
VALA_MESON_DISABLE_FLAG = "disabled"
|
||||
GIDOCGEN_MESON_OPTION = "gi-docgen"
|
||||
GIDOCGEN_MESON_ENABLE_FLAG = "enabled"
|
||||
GIDOCGEN_MESON_DISABLE_FLAG = "disabled"
|
||||
|
||||
SRC_URI = "https://download.gimp.org/gimp/v3.0/gimp-${PV}.tar.xz"
|
||||
SRC_URI += "file://0001-gimp-cross-compile-fix-for-bz2.patch"
|
||||
SRC_URI += "file://0002-meson.build-reproducibility-fix.patch"
|
||||
SRC_URI[sha256sum] = "93f1ca3d9d1bd8cac0e52c49fb886cbbe4b28222ee835bf1319e3287901d2d20"
|
||||
|
||||
PACKAGECONFIG[aa] = "-Daa=enabled,-Daa=disabled,aalib"
|
||||
PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
|
||||
PACKAGECONFIG[appdata-test] = "-Dappdata-test=enabled,-Dappdata-test=disabled,appstream-glib-native"
|
||||
PACKAGECONFIG[cairo-pdf] = "-Dcairo-pdf=enabled,-Dcairo-pdf=disabled"
|
||||
PACKAGECONFIG[check-update] = "-Dcheck-update=yes,-Dcheck-update=no"
|
||||
PACKAGECONFIG[ghostscript] = "-Dghostscript=enabled,-Dghostscript=disabled,ghostscript,ghostscript"
|
||||
PACKAGECONFIG[gudev] = "-Dgudev=enabled,-Dgudev=disabled,libgudev"
|
||||
PACKAGECONFIG[heif] = "-Dheif=enabled,-Dheif=disabled,libheif"
|
||||
PACKAGECONFIG[javascript] = "-Djavascript=enabled,-Djavascript=disabled,,gjs"
|
||||
PACKAGECONFIG[jpeg2000] = "-Djpeg2000=enabled,-Djpeg2000=disabled,jasper"
|
||||
PACKAGECONFIG[jpeg-xl] = "-Djpeg-xl=enabled,-Djpeg-xl=disabled,libjxl"
|
||||
PACKAGECONFIG[libunwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
|
||||
PACKAGECONFIG[libbacktrace] = "-Dlibbacktrace=true,-Dlibbacktrace=false,libbacktrace"
|
||||
PACKAGECONFIG[lua] = "-Dlua=true,-Dlua=false,,luajit lua-lgi"
|
||||
PACKAGECONFIG[mng] = "-Dmng=enabled,-Dmng=disabled,libmng"
|
||||
PACKAGECONFIG[openmp] = "-Dopenmp=enabled,-Dopenmp=disabled,gcc-runtime"
|
||||
PACKAGECONFIG[vector-icons] = "-Dvector-icons=true,-Dvector-icons=false,librsvg shared-mime-info"
|
||||
PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
|
||||
PACKAGECONFIG[xcursor] = "-Dxcursor=enabled,-Dxcursor=disabled,libxcursor"
|
||||
PACKAGECONFIG[x11] = "-Dxpm=enabled,-Dxpm=disabled,libxpm libxext libxfixes"
|
||||
|
||||
PACKAGECONFIG ?= " \
|
||||
aa \
|
||||
alsa \
|
||||
cairo-pdf \
|
||||
ghostscript \
|
||||
gudev \
|
||||
heif \
|
||||
javascript \
|
||||
jpeg2000 \
|
||||
jpeg-xl \
|
||||
lua \
|
||||
mng \
|
||||
vector-icons \
|
||||
webp \
|
||||
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcursor', '', d)} \
|
||||
"
|
||||
|
||||
PACKAGECONFIG:remove:riscv32 = "lua"
|
||||
PACKAGECONFIG:remove:riscv64 = "lua"
|
||||
PACKAGECONFIG:remove:powerpc64 = "lua"
|
||||
PACKAGECONFIG:remove:powerpc64le = "lua"
|
||||
|
||||
FILES:${PN} += "${datadir}/metainfo"
|
||||
|
||||
EXTRA_OEMESON += " \
|
||||
-Dshmem-type=posix \
|
||||
-Dlinux-input=enabled \
|
||||
--buildtype release \
|
||||
--cross-file=${WORKDIR}/meson-${PN}.cross \
|
||||
"
|
||||
|
||||
do_write_config:append() {
|
||||
cat >${WORKDIR}/meson-${PN}.cross <<EOF
|
||||
[binaries]
|
||||
gjs = '${bindir}/gjs'
|
||||
luajit = '${bindir}/luajit'
|
||||
EOF
|
||||
}
|
||||
|
||||
do_configure:append () {
|
||||
sed -i -e "s|build_by_default: true|build_by_default: false|" ${S}/gimp-data/images/meson.build
|
||||
}
|
||||
|
||||
do_install:prepend() {
|
||||
sed -i -e "s|${B}||" ${B}/app/widgets/gimplanguagestore-data.h
|
||||
sed -i -e "s|${B}||" ${B}/plug-ins/file-bmp/huffman.h
|
||||
}
|
||||
|
||||
RDEPENDS:${PN} = "mypaint-brushes-1.0 glib-networking python3-pygobject"
|
Loading…
x
Reference in New Issue
Block a user