u-boot: upgrade to 2018.03

This version of u-boot includes nanopi-neo-plus2 support.

Signed-off-by: Martin Kelly <mkelly@xevo.com>
This commit is contained in:
Martin Kelly 2018-04-12 14:28:03 -07:00
parent 073dbda366
commit 5e61ba92e3
9 changed files with 25 additions and 21 deletions

View File

@ -5,7 +5,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2017.11%"
PREFERRED_VERSION_u-boot = "v2018.03%"
KERNEL_DEVICETREE = "sun8i-h3-nanopi-neo-air.dtb"
UBOOT_MACHINE = "nanopi_neo_air_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2017.11%"
PREFERRED_VERSION_u-boot = "v2018.03%"
KERNEL_DEVICETREE = "sun8i-h3-nanopi-neo.dtb"
UBOOT_MACHINE = "nanopi_neo_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2017.11%"
PREFERRED_VERSION_u-boot = "v2018.03%"
KERNEL_DEVICETREE = "sun8i-h3-orangepi-one.dtb"
UBOOT_MACHINE = "orangepi_one_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2017.11%"
PREFERRED_VERSION_u-boot = "v2018.03%"
KERNEL_DEVICETREE = "sun8i-h3-orangepi-pc.dtb"
UBOOT_MACHINE = "orangepi_pc_defconfig"

View File

@ -5,7 +5,7 @@
require conf/machine/include/sun50i.inc
PREFERRED_VERSION_u-boot = "v2017.11%"
PREFERRED_VERSION_u-boot = "v2018.03%"
KERNEL_DEVICETREE = "allwinner/sun50i-h5-orangepi-zero-plus2.dtb"
UBOOT_MACHINE = "orangepi_zero_plus2_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2017.11%"
PREFERRED_VERSION_u-boot = "v2018.03%"
KERNEL_DEVICETREE = "sun8i-h2-plus-orangepi-zero.dtb"
UBOOT_MACHINE = "orangepi_zero_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun4i.inc
PREFERRED_VERSION_u-boot = "v2017.11%"
PREFERRED_VERSION_u-boot = "v2018.03%"
KERNEL_DEVICETREE = "sun4i-a10-pcduino.dtb"
UBOOT_MACHINE = "Linksprite_pcDuino_defconfig"

View File

@ -1,12 +1,16 @@
diff --git a/tools/Makefile b/tools/Makefile
index 5db2a54..54bd224 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -134,6 +134,7 @@ tools/_libfdt.so: $(LIBFDT_SRCS) $(LIBFDT_SWIG)
$(Q)unset CC; \
unset CROSS_COMPILE; \
LDFLAGS="$(HOSTLDFLAGS)" CFLAGS= VERSION="u-boot-$(UBOOTVERSION)" \
+ CC="$(HOSTCC)" LDSHARED="$(HOSTLDSHARED)" \
CPPFLAGS="$(_hostc_flags)" OBJDIR=tools \
SOURCES="$(LIBFDT_SRCS) tools/libfdt.i" \
SWIG_OPTS="-I$(srctree)/lib/libfdt -I$(srctree)/lib" \
diff --git a/scripts/dtc/pylibfdt/Makefile b/scripts/dtc/pylibfdt/Makefile
index 01d5e0ffe3..2b2dfe0bd9 100644
--- a/scripts/dtc/pylibfdt/Makefile
+++ b/scripts/dtc/pylibfdt/Makefile
@@ -15,6 +15,8 @@ PYLIBFDT_srcs = $(addprefix $(LIBFDT_srcdir)/,$(LIBFDT_SRCS)) \
quiet_cmd_pymod = PYMOD $@
cmd_pymod = unset CC; unset CROSS_COMPILE; unset CFLAGS;\
+ CC="$(HOSTCC)" \
+ LDSHARED="$(HOSTLDSHARED)" \
LDFLAGS="$(HOSTLDFLAGS)" \
VERSION="u-boot-$(UBOOTVERSION)" \
CPPFLAGS="$(HOSTCFLAGS) -I$(LIBFDT_srcdir)" OBJDIR=$(obj) \
--
2.11.0

View File

@ -21,9 +21,9 @@ SRC_URI = "git://git.denx.de/u-boot.git;branch=master \
file://boot.cmd \
"
SRCREV = "c253573f3e269fd9a24ee6684d87dd91106018a5"
SRCREV = "f95ab1fb6e37f0601f397091bb011edf7a98b890"
PV = "v2017.11+git${SRCPV}"
PV = "v2018.03+git${SRCPV}"
PE = "2"
S = "${WORKDIR}/git"