Merge pull request #50 from KristofRobot/libdri2

libdri2 patch (resolves #23)
This commit is contained in:
Aguirre 2014-03-21 07:44:00 +01:00
commit 43fe715ea4
2 changed files with 1 additions and 41 deletions

View File

@ -1,40 +0,0 @@
From 9f72dadae695f64631d4de361c2862683d5c9ccc Mon Sep 17 00:00:00 2001
From: Nicolas Aguirre <aguirre.nicolas@gmail.com>
Date: Fri, 13 Sep 2013 00:23:28 +0200
Subject: [PATCH] fix build by removing dri2 link for libump and adding lX11
for tests
---
lib/ump/Makefile | 2 +-
test/Makefile | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/ump/Makefile b/lib/ump/Makefile
index c3da96b..d5fcb01 100644
--- a/lib/ump/Makefile
+++ b/lib/ump/Makefile
@@ -7,7 +7,7 @@ CFLAGS += -Wall -O3 -fPIC
LDFLAGS += -Wl,--no-as-needed
ifeq ($(MALI_EGL_TYPE),x11)
- LDFLAGS += -ldri2 -ldrm -lXfixes
+ LDFLAGS += -ldrm -lXfixes
endif
BARE_TARGET = libUMP.so
diff --git a/test/Makefile b/test/Makefile
index 700416e..fa652f9 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -5,7 +5,7 @@ CFLAGS ?= -Wall
all: test
test: ../config.mk test.c
- $(CC) $(CFLAGS) -o $@ test.c -lEGL -lGLESv2
+ $(CC) $(CFLAGS) -o $@ test.c -lEGL -lGLESv2 -lX11
clean:
rm -f test
--
1.8.4

View File

@ -3,7 +3,7 @@ DESCRIPTION = "Library for the DRI2 extension to the X Window System"
LICENSE = "MIT-X"
LIC_FILES_CHKSUM = "file://COPYING;md5=827da9afab1f727f2a66574629e0f39c"
DEPENDS = "libdrm libxext xextproto libxfixes"
DEPENDS = "libdrm libxext xextproto libxfixes dri2proto"
PE = "1"
PV = "1.0.0+git${SRCPV}"