1
0
mirror of https://github.com/lxsang/meta-rpi-diya.git synced 2024-10-04 22:36:38 +02:00

add raspi-gpio tools

This commit is contained in:
DanyLE 2023-07-09 16:47:38 +02:00
parent e1189cfc1d
commit 787af3e0ad
2 changed files with 49 additions and 0 deletions

31
libsdl2.patch Normal file
View File

@ -0,0 +1,31 @@
diff --git a/conf/layer.conf b/conf/layer.conf
index 2fa87d9..eb141fb 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -2,8 +2,8 @@
BBPATH .= ":${LAYERDIR}"
# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
+BBFILES += " ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend "
BBFILE_COLLECTIONS += "meta-rpi-diya"
BBFILE_PATTERN_meta-rpi-diya = "^${LAYERDIR}/"
diff --git a/recipes-graphics/libsdl2/libsdl2_%.bbappend b/recipes-graphics/libsdl2/libsdl2_%.bbappend
index 937abb6..8e22324 100644
--- a/recipes-graphics/libsdl2/libsdl2_%.bbappend
+++ b/recipes-graphics/libsdl2/libsdl2_%.bbappend
@@ -1,6 +1,4 @@
DEPENS += " mesa libdrm virtual/libgbm virtual/libgles2 "
-# alsa
-EXTRA_OECONF:append=" --disable-video-x11 \
- --disable-video-wayland \
- --enable-video-kmsdrm \
- --enable-video-opengles"
\ No newline at end of file
+
+PACKAGECONFIG = " kmsdrm opengl gles2 "
+# PACKAGECONFIG:remove = "x11 wayland"
\ No newline at end of file

View File

@ -0,0 +1,18 @@
DESCRIPTION = "raspi GPIO tools"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
# FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
# DEPENDS = " "
# code
# SRCREV = "${AUTOREV}"
SRC_URI = "git://github.com/RPi-Distro/raspi-gpio.git"
# S="${WORKDIR}/git/platforms/unix/config"
# B="${WORKDIR}/build"
inherit autotools