meta-wayland/recipes-support/hyprland/hyprland-contrib_git.bb
2024-12-05 09:44:53 +01:00

25 lines
756 B
BlitzBasic

SUMMARY = "Hyprland Contribution Scripts"
HOMEPAGE = "https:/github.com/hyprwm/contrib"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a0836e8f0d25d383d1195ea44fdd185d"
SRC_URI = "git://github.com/hyprwm/contrib.git;protocol=https;branch=main"
S = "${WORKDIR}/git"
SRCREV = "d7c55140f1785b8d9fef351f1cd2a4c9e1eaa466"
PV = "0.1"
DEPENDS = "scdoc-native"
RDEPENDS:${PN} = "bash sed jq libnotify grim slurp wl-clipboard"
EXTRA_OEMAKE += "DESTDIR=${D} PREFIX=${prefix} BINDIR=${D}${bindir} MANDIR=${D}${datadir}/man MAN1DIR=${D}${datadir}/man1"
do_install() {
for dir in hyprprop hdrop shellevents try_swap_workspace scratchpad grimblast; do
cd $dir && oe_runmake && oe_runmake install && cd ${S}
done
}
FILES:${PN} = "${bindir} ${datadir}"