mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-19 20:08:27 +01:00
27 lines
710 B
BlitzBasic
27 lines
710 B
BlitzBasic
SUMMARY = "nwg-bar for wlroots based compositors."
|
|
DESCRIPTION = "The nwg-bar command creates a button bar on the basis of a JSON template placed in the ~/.config/nwg-bar/ folder."
|
|
LICENSE = "MIT"
|
|
LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=dcdbccfd08fcfd7002d16ca7fa5ad5cb"
|
|
|
|
DEPENDS = " \
|
|
gtk+3 \
|
|
gtk-layer-shell \
|
|
"
|
|
RDEPENDS:${PN} = "go-runtime"
|
|
|
|
GO_IMPORT = "github.com/nwg-piotr/nwg-bar.git"
|
|
|
|
SRC_URI = "git://${GO_IMPORT};destsuffix=src/${GO_IMPORT};nobranch=1;protocol=https"
|
|
|
|
PV = "0.1.5"
|
|
SRCREV = "86f75d0856193c1ba1505f6afbc1b73d34c7093a"
|
|
S = "${WORKDIR}/sources"
|
|
UNPACKDIR = "${S}"
|
|
|
|
inherit go go-mod pkgconfig
|
|
|
|
GO_INSTALL = "${GO_IMPORT}"
|
|
GO_LINKSHARED = ""
|
|
|
|
do_compile[network] = "1"
|