mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-12-26 13:38:22 +01:00
gimp: update
This commit is contained in:
parent
99d95fa55b
commit
f1c1429352
@ -0,0 +1,30 @@
|
||||
From a7e40e19d17404cf5ec4135fc1becd5a90f5e1e1 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Wed, 25 Dec 2024 07:27:04 +0100
|
||||
Subject: [PATCH] gimp: cross-compile fix for bz2
|
||||
|
||||
Upstream-Status: Inappropriate [can probably be removed once bzip2 is built with meson or cmake]
|
||||
|
||||
autotools bzip2 build does not create pkgconfig files so looking for the dependency fails.
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 4e48f8c64c..d5dce47015 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -765,7 +765,7 @@ zlib = dependency('zlib')
|
||||
MIMEtypes += 'image/x-psp'
|
||||
|
||||
# Compiler-provided headers can't be found in crossroads environment
|
||||
-if not meson.is_cross_build()
|
||||
+if true
|
||||
bz2 = cc.find_library('bz2')
|
||||
else
|
||||
bz2 = dependency('bzip2')
|
||||
--
|
||||
2.47.1
|
||||
|
@ -1,43 +0,0 @@
|
||||
From c8f73f57d63779cfaad140e0521be40972fbec8f Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Wed, 1 Sep 2021 16:44:13 +0200
|
||||
Subject: [PATCH] meson: make gir buildable
|
||||
|
||||
yocto/oe is capable of building gobject introspection despite cross-compiling.
|
||||
add an option to enable gir build even if cross-compiling
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
libgimp/meson.build | 2 +-
|
||||
meson_options.txt | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/libgimp/meson.build b/libgimp/meson.build
|
||||
index 9e7b4fbbe3..99614733d7 100644
|
||||
--- a/libgimp/meson.build
|
||||
+++ b/libgimp/meson.build
|
||||
@@ -384,7 +384,7 @@ libgimpui_introspectable_files = [
|
||||
libgimpwidgets_introspectable,
|
||||
]
|
||||
|
||||
-if meson.is_cross_build()
|
||||
+if meson.is_cross_build() and not get_option('introspection')
|
||||
have_gobject_introspection = false
|
||||
gobject_introspection_warning = '\n '.join(['',
|
||||
'GObject Introspection is disabled while cross-compiling because',
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index 7b6ad78045..c29fdb5b40 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -52,7 +52,7 @@ option('headless-tests', type: 'feature', value: 'auto', description: 'Use xv
|
||||
option('gtk-doc', type: 'boolean', value: true, description: 'Build developer documentation')
|
||||
option('gtk-doc-app', type: 'boolean', value: false, description: 'Build developer documentation for app')
|
||||
option('g-ir-doc', type: 'boolean', value: false, description: 'Build developer documentation for introspected API')
|
||||
-
|
||||
+option('introspection', type: 'boolean', value: false, description: 'GIR is buildable even if crosscompiling')
|
||||
option('linux-input', type: 'feature', value: 'auto', description: 'Linux input event controller module')
|
||||
option('vec-icons', type: 'boolean', value: true, description: 'Use vector icons rather than raster ones')
|
||||
|
||||
--
|
||||
2.25.1
|
||||
|
@ -8,6 +8,7 @@ DEPENDS = " \
|
||||
appstream-glib \
|
||||
atk \
|
||||
babl \
|
||||
bzip2 \
|
||||
bison-native \
|
||||
cairo \
|
||||
dbus-glib \
|
||||
@ -15,7 +16,6 @@ DEPENDS = " \
|
||||
freetype \
|
||||
gdk-pixbuf-native \
|
||||
gegl \
|
||||
gegl-native \
|
||||
gexiv2 \
|
||||
gtk+3 \
|
||||
harfbuzz \
|
||||
@ -31,10 +31,11 @@ DEPENDS = " \
|
||||
pango \
|
||||
poppler \
|
||||
poppler-data \
|
||||
python3-pygobject-native \
|
||||
"
|
||||
|
||||
DEPENDS:append:libc-musl = " libexecinfo"
|
||||
RDEPENDS:${PN} = "mypaint-brushes-1.0 glib-networking"
|
||||
RDEPENDS:${PN} = "mypaint-brushes-1.0 glib-networking python3-pygobject"
|
||||
|
||||
inherit meson gtk-icon-cache mime-xdg pkgconfig gettext gobject-introspection vala
|
||||
|
||||
@ -46,33 +47,30 @@ GIDOCGEN_MESON_OPTION = "gi-docgen"
|
||||
GIDOCGEN_MESON_ENABLE_FLAG = "enabled"
|
||||
GIDOCGEN_MESON_DISABLE_FLAG = "disabled"
|
||||
|
||||
SRC_URI = "git://github.com/GNOME/gimp.git;protocol=https;branch=master"
|
||||
|
||||
SRC_URI = "gitsm://github.com/GNOME/gimp.git;protocol=https;branch=master"
|
||||
SRC_URI += "file://0001-gimp-cross-compile-fix-for-bz2.patch"
|
||||
S = "${WORKDIR}/git"
|
||||
SRCREV = "f94c4cb5dbf9766b27ecb5016b7a39497cc74ddc"
|
||||
PV = "2.99.18"
|
||||
SRCREV = "461d5db07e4931ebf5fd293eeddd85f2d7a6aa62"
|
||||
PV = "3.0.0-RC-1"
|
||||
|
||||
PACKAGECONFIG[aa] = "-Daa=enabled,-Daa=disabled,aalib"
|
||||
PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
|
||||
PACKAGECONFIG[appdata-test] = "-Dappdata-test=enabled,-Dappdata-test=disabled,appstream-glib-native"
|
||||
PACKAGECONFIG[bzip2] = ",,bzip2"
|
||||
PACKAGECONFIG[cairo-pdf] = "-Dcairo-pdf=enabled,-Dcairo-pdf=disabled"
|
||||
PACKAGECONFIG[check-update] = "-Dcheck-update=yes,-Dcheck-update=no"
|
||||
PACKAGECONFIG[enable-console-bin] = "-Denable-console-bin=true,-Denable-console-bin=false"
|
||||
PACKAGECONFIG[ghostscript] = "-Dghostscript=enabled,-Dghostscript=disabled,ghostscript,ghostscript"
|
||||
PACKAGECONFIG[gudev] = "-Dgudev=enabled,-Dgudev=disabled,libgudev"
|
||||
PACKAGECONFIG[iso-codes] = ",,iso-codes"
|
||||
PACKAGECONFIG[javascript] = "-Djavascript=enabled,-Djavascript=disabled,gjs"
|
||||
PACKAGECONFIG[javascript] = "-Djavascript=enabled,-Djavascript=disabled,,gjs"
|
||||
PACKAGECONFIG[jpeg2000] = "-Djpeg2000=enabled,-Djpeg2000=disabled,jasper"
|
||||
PACKAGECONFIG[jpeg] = ",,jpeg"
|
||||
PACKAGECONFIG[jpeg-xl] = ",,libjxl"
|
||||
PACKAGECONFIG[libunwind] = ",,libunwind"
|
||||
PACKAGECONFIG[libbacktrace] = ",,libbacktrace"
|
||||
PACKAGECONFIG[lua] = "-Dlua=enabled,-Dlua=disabled,luajit"
|
||||
PACKAGECONFIG[lua] = "-Dlua=true,-Dlua=false,,luajit lua-lgi"
|
||||
PACKAGECONFIG[lzma] = ",,xz"
|
||||
PACKAGECONFIG[mng] = "-Dmng=enabled,-Dmng=disabled,libmng"
|
||||
PACKAGECONFIG[python] = "-Dpython=enabled,-Dpython=disabled,,python3-core python3-pygobject"
|
||||
PACKAGECONFIG[rsvg] = ",,librsvg"
|
||||
PACKAGECONFIG[rsvg] = ",,librsvg-native librsvg"
|
||||
PACKAGECONFIG[tiff] = ",,tiff"
|
||||
PACKAGECONFIG[vector-icons] = "-Dvector-icons=true,-Dvector-icons=false,librsvg shared-mime-info"
|
||||
PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
|
||||
@ -81,19 +79,19 @@ PACKAGECONFIG[x11] = "-Dxpm=enabled,-Dxpm=disabled,libxpm libxext libxfixes"
|
||||
PACKAGECONFIG[zlib] = ",,zlib"
|
||||
|
||||
PACKAGECONFIG ?= " \
|
||||
${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
|
||||
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcursor', '', d)} \
|
||||
aa \
|
||||
alsa \
|
||||
bzip2 \
|
||||
cairo-pdf \
|
||||
ghostscript \
|
||||
gudev \
|
||||
javascript \
|
||||
jpeg \
|
||||
jpeg2000 \
|
||||
jpeg-xl \
|
||||
lua \
|
||||
lzma \
|
||||
mng \
|
||||
python \
|
||||
rsvg \
|
||||
tiff \
|
||||
vector-icons \
|
||||
@ -101,15 +99,34 @@ PACKAGECONFIG ?= " \
|
||||
zlib \
|
||||
"
|
||||
|
||||
PACKAGECONFIG:remove:riscv32 = "lua"
|
||||
PACKAGECONFIG:remove:riscv64 = "lua"
|
||||
PACKAGECONFIG:remove:powerpc64 = "lua"
|
||||
PACKAGECONFIG:remove:powerpc64le = "lua"
|
||||
|
||||
FILES:${PN} += "${datadir}/metainfo"
|
||||
|
||||
EXTRA_OEMESON += " \
|
||||
-Dshmem-type=posix \
|
||||
-Dlinux-input=enabled \
|
||||
--buildtype release \
|
||||
--cross-file=${WORKDIR}/meson-${PN}.cross \
|
||||
"
|
||||
|
||||
do_write_config:append() {
|
||||
cat >${WORKDIR}/meson-${PN}.cross <<EOF
|
||||
[binaries]
|
||||
gjs = '${bindir}/gjs'
|
||||
luajit = '${bindir}/luajit'
|
||||
EOF
|
||||
}
|
||||
|
||||
do_configure:append () {
|
||||
sed -i -e "s|${RECIPE_SYSROOT_NATIVE}||" ${B}/config.h
|
||||
sed -i -e "s|${RECIPE_SYSROOT_NATIVE}||" ${B}/config.h
|
||||
}
|
||||
|
||||
do_install:prepend() {
|
||||
sed -i -e "s|${B}||" ${B}/app/widgets/gimplanguagestore-data.h
|
||||
sed -i -e "s|${B}||" ${B}/plug-ins/file-bmp/huffman.h
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user