mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2025-01-27 15:02:48 +01:00
gimp: fix crosscompile issues
This commit is contained in:
parent
e0410420a9
commit
ea6f3b4000
@ -3,11 +3,11 @@ From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Wed, 25 Dec 2024 07:27:04 +0100
|
||||
Subject: [PATCH] gimp: cross-compile fix for bz2
|
||||
|
||||
Upstream-Status: Inappropriate [can probably be removed once bzip2 is built with meson or cmake]
|
||||
|
||||
autotools bzip2 build does not create pkgconfig files so looking for the dependency fails.
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
|
||||
Upstream-Status: Inappropriate [can probably be removed once bzip2 is built with meson or cmake]
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
@ -0,0 +1,56 @@
|
||||
From bf19c5687703769e406a8086036d4ed6421c33cb Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Mon, 13 Jan 2025 10:04:33 +0100
|
||||
Subject: [PATCH] meson.build: reproducibility fix
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
|
||||
Upstream-Status: Inappropriate [oe-specific]
|
||||
---
|
||||
meson.build | 28 ++++++++++++++--------------
|
||||
1 file changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 97cd621780..e47180db87 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1599,23 +1599,23 @@ conf.set('HAVE_FUNC_ATTRIBUTE_DESTRUCTOR',
|
||||
conf.set_quoted('CC', cc.get_id())
|
||||
|
||||
cc_version=''
|
||||
-if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
||||
- cc_cmd = run_command(cc, '-v', check: false)
|
||||
+#if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
||||
+# cc_cmd = run_command(cc, '-v', check: false)
|
||||
# Note: the call might actually fail when using ccache.
|
||||
# See: https://github.com/mesonbuild/meson/issues/6174
|
||||
- if cc_cmd.returncode() == 0
|
||||
- cc_version = cc_cmd.stdout() + cc_cmd.stderr()
|
||||
- endif
|
||||
-else
|
||||
+# if cc_cmd.returncode() == 0
|
||||
+# cc_version = cc_cmd.stdout() + cc_cmd.stderr()
|
||||
+# endif
|
||||
+#else
|
||||
# Various compilers have various options. Try most common ones. This
|
||||
# list of options comes from autotools checks.
|
||||
- foreach arg : [ '--version', '-v', '-V', '-qversion' ]
|
||||
- cc_cmd = run_command(cc, arg, check: false)
|
||||
- if cc_cmd.returncode() == 0
|
||||
- cc_version = cc_cmd.stdout()
|
||||
- endif
|
||||
- endforeach
|
||||
-endif
|
||||
+# foreach arg : [ '--version', '-v', '-V', '-qversion' ]
|
||||
+# cc_cmd = run_command(cc, arg, check: false)
|
||||
+# if cc_cmd.returncode() == 0
|
||||
+# cc_version = cc_cmd.stdout()
|
||||
+# endif
|
||||
+# endforeach
|
||||
+#endif
|
||||
if cc_version == ''
|
||||
# We didn't manage to get a meaningful verbose version from the
|
||||
# compiler. Just save its name and version.
|
||||
--
|
||||
2.47.1
|
||||
|
@ -56,12 +56,11 @@ GIDOCGEN_MESON_DISABLE_FLAG = "disabled"
|
||||
|
||||
SRC_URI = "gitsm://github.com/GNOME/gimp.git;protocol=https;branch=master"
|
||||
SRC_URI += "file://0001-gimp-cross-compile-fix-for-bz2.patch"
|
||||
SRC_URI += "file://0002-meson.build-reproducibility-fix.patch"
|
||||
S = "${WORKDIR}/git"
|
||||
SRCREV = "d52117a7f753353b5f900d8195a2443c603d6c94"
|
||||
PV = "3.0.0-RC-2"
|
||||
|
||||
export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
|
||||
|
||||
PACKAGECONFIG[aa] = "-Daa=enabled,-Daa=disabled,aalib"
|
||||
PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
|
||||
PACKAGECONFIG[appdata-test] = "-Dappdata-test=enabled,-Dappdata-test=disabled,appstream-glib-native"
|
||||
@ -123,8 +122,7 @@ EOF
|
||||
}
|
||||
|
||||
do_configure:append () {
|
||||
sed -i -e "s|${RECIPE_SYSROOT_NATIVE}||" ${B}/config.h
|
||||
sed -i -e "s|${RECIPE_SYSROOT_NATIVE}||" ${B}/config.h
|
||||
sed -i -e "s|build_by_default: true|build_by_default: false|" ${S}/gimp-data/images/meson.build
|
||||
}
|
||||
|
||||
do_install:prepend() {
|
||||
|
Loading…
x
Reference in New Issue
Block a user