mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-20 04:18:25 +01:00
foot: add sways default terminal emulator
add foot and RRECOMMAND it to have the default terminal emulator installed
This commit is contained in:
parent
8044de610c
commit
e4e03315c2
@ -0,0 +1,28 @@
|
||||
From 8b19cc784d4f0b56e45e22c911b7f9671ae92ca4 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Sun, 6 Jun 2021 18:23:06 +0200
|
||||
Subject: [PATCH] meson.build: avoid scdoc dependency
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
meson.build | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 11ac4cb..8a14738 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -123,9 +123,8 @@ if not meson.is_subproject()
|
||||
|
||||
install_data(
|
||||
'LICENSE', 'README.md', 'CHANGELOG.md',
|
||||
- install_dir: join_paths(get_option('datadir'), 'doc', 'fcft'))
|
||||
+ install_dir: join_paths(get_option('datadir'), 'fcft'))
|
||||
|
||||
- subdir('doc')
|
||||
endif
|
||||
|
||||
summary(
|
||||
--
|
||||
2.25.1
|
||||
|
29
recipes-support/foot/fcft_git.bb
Normal file
29
recipes-support/foot/fcft_git.bb
Normal file
@ -0,0 +1,29 @@
|
||||
SUMMARY = "A simple library for font loading and glyph rasterization using FontConfig, FreeType and pixman."
|
||||
HOMEPAGE = "https://codeberg.org/dnkl/fcft"
|
||||
BUGTRACKER = "https://codeberg.org/dnkl/fcft/issues"
|
||||
SECTION = "base/shell"
|
||||
LICENSE = "MIT"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3a7351a597a91e763901f7c76f21e798"
|
||||
|
||||
DEPENDS = " \
|
||||
fontconfig \
|
||||
freetype \
|
||||
harfbuzz \
|
||||
pixman \
|
||||
tllist \
|
||||
"
|
||||
|
||||
SRC_URI = " \
|
||||
git://codeberg.org/dnkl/fcft.git;protocol=https \
|
||||
file://0001-meson.build-avoid-scdoc-dependency.patch \
|
||||
"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
PV = "2.4.0"
|
||||
SRCREV = "${PV}"
|
||||
|
||||
inherit meson pkgconfig
|
||||
|
||||
BBCLASSEXTEND = ""
|
||||
|
@ -0,0 +1,33 @@
|
||||
From bd5d23cc82e9f7c065571b6695fe024c6f51051e Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Sun, 6 Jun 2021 18:25:08 +0200
|
||||
Subject: [PATCH] meson.build: avoid scdoc dependency
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
meson.build | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 50cc9eb..993b7fd 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -220,14 +220,13 @@ endif
|
||||
|
||||
install_data(
|
||||
'LICENSE', 'README.md', 'CHANGELOG.md',
|
||||
- install_dir: join_paths(get_option('datadir'), 'doc', 'foot'))
|
||||
+ install_dir: join_paths(get_option('datadir'), 'foot'))
|
||||
install_data(
|
||||
'foot.desktop', 'foot-server.desktop',
|
||||
install_dir: join_paths(get_option('datadir'), 'applications'))
|
||||
install_data('foot.ini', install_dir: join_paths(get_option('datadir'), 'foot'))
|
||||
|
||||
subdir('completions')
|
||||
-subdir('doc')
|
||||
subdir('icons')
|
||||
|
||||
summary(
|
||||
--
|
||||
2.25.1
|
||||
|
40
recipes-support/foot/foot_git.bb
Normal file
40
recipes-support/foot/foot_git.bb
Normal file
@ -0,0 +1,40 @@
|
||||
SUMMARY = "A fast, lightweight and minimalistic Wayland terminal emulator."
|
||||
HOMEPAGE = "https://codeberg.org/dnkl/foot"
|
||||
BUGTRACKER = "https://codeberg.org/dnkl/foot/issues"
|
||||
SECTION = "base/shell"
|
||||
LICENSE = "MIT"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3a7351a597a91e763901f7c76f21e798"
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
DEPENDS = " \
|
||||
fcft \
|
||||
fontconfig \
|
||||
freetype \
|
||||
libxkbcommon \
|
||||
pixman \
|
||||
wayland \
|
||||
wayland-native \
|
||||
"
|
||||
|
||||
SRC_URI = " \
|
||||
git://codeberg.org/dnkl/foot.git;protocol=https \
|
||||
file://0001-meson.build-avoid-scdoc-dependency.patch \
|
||||
"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
PV = "1.7.2"
|
||||
SRCREV = "${PV}"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
||||
EXTRA_OEMESON += "-Dterminfo=disabled"
|
||||
|
||||
FILES_${PN} = " \
|
||||
${bindir} \
|
||||
${datadir} \
|
||||
"
|
||||
|
||||
BBCLASSEXTEND = ""
|
||||
|
20
recipes-support/foot/tllist_git.bb
Normal file
20
recipes-support/foot/tllist_git.bb
Normal file
@ -0,0 +1,20 @@
|
||||
SUMMARY = "A C header file only implementation of a typed linked list."
|
||||
HOMEPAGE = "https://codeberg.org/dnkl/tllist"
|
||||
BUGTRACKER = "https://codeberg.org/dnkl/tllist/issues"
|
||||
SECTION = "base/shell"
|
||||
LICENSE = "MIT"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3a7351a597a91e763901f7c76f21e798"
|
||||
|
||||
SRC_URI = " \
|
||||
git://codeberg.org/dnkl/tllist.git;protocol=https \
|
||||
"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
PV = "1.0.5"
|
||||
SRCREV = "${PV}"
|
||||
|
||||
inherit meson pkgconfig
|
||||
|
||||
BBCLASSEXTEND = ""
|
||||
|
@ -25,7 +25,11 @@ DEPENDS += " \
|
||||
wayland-protocols \
|
||||
"
|
||||
# sways default config makes use of it
|
||||
RDEPENDS_${PN} = "swaybg"
|
||||
RDEPENDS_${PN} ?= "swaybg"
|
||||
|
||||
RRECOMMENDS_${PN} ?= " \
|
||||
foot \
|
||||
"
|
||||
|
||||
SRC_URI = " \
|
||||
git://github.com/swaywm/sway.git;protocol=https \
|
||||
|
Loading…
Reference in New Issue
Block a user