Hyprland: Update

This commit is contained in:
Markus Volk 2023-09-23 22:14:21 +02:00
parent c6c55f198a
commit e3daa9c355
2 changed files with 21 additions and 28 deletions

View File

@ -1,14 +1,5 @@
From 6218794fafe27f74770d616626d9af570dabfbf6 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Sat, 22 Jul 2023 00:55:42 +0200
Subject: [PATCH] meson-build
---
meson.build | 15 +++------------
1 file changed, 3 insertions(+), 12 deletions(-)
diff --git a/meson.build b/meson.build diff --git a/meson.build b/meson.build
index 6a94dee6..3049e1ce 100644 index f3802553..6a924a79 100644
--- a/meson.build --- a/meson.build
+++ b/meson.build +++ b/meson.build
@@ -21,9 +21,9 @@ else @@ -21,9 +21,9 @@ else
@ -23,34 +14,35 @@ index 6a94dee6..3049e1ce 100644
add_project_arguments( add_project_arguments(
[ [
@@ -39,20 +39,11 @@ add_project_arguments( @@ -39,21 +39,8 @@ add_project_arguments(
], ],
language: 'cpp') language: 'cpp')
-wlroots = subproject('wlroots', default_options: ['examples=false']) -wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
-have_xwlr = wlroots.get_variable('features').get('xwayland') -have_xwlr = wlroots.get_variable('features').get('xwayland')
-xcb_dep = dependency('xcb', required: get_option('xwayland')) -xcb_dep = dependency('xcb', required: get_option('xwayland'))
- -
cmake = import('cmake') -cmake = import('cmake')
udis = cmake.subproject('udis86') -udis = cmake.subproject('udis86')
udis86 = udis.dependency('libudis86') -udis86 = udis.dependency('libudis86')
-
-if get_option('xwayland').enabled() and not have_xwlr -if get_option('xwayland').enabled() and not have_xwlr
- error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support') - error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support')
-endif -endif
-have_xwayland = xcb_dep.found() and have_xwlr -have_xwayland = xcb_dep.found() and have_xwlr
- -
-if not have_xwayland -if not have_xwayland
- add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
+if get_option('xwayland').disabled() +if get_option('xwayland').disabled()
add_project_arguments('-DNO_XWAYLAND', language: 'cpp') + add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif endif
backtrace_dep = cpp_compiler.find_library('execinfo', required: false)
-- diff --git a/src/meson.build b/src/meson.build diff --git a/src/meson.build b/src/meson.build
index 8430f597..da041dd9 100644 index 7b658d31..60aa4057 100644
--- a/src/meson.build --- a/src/meson.build
+++ b/src/meson.build +++ b/src/meson.build
@@ -8,13 +8,13 @@ executable('Hyprland', src, @@ -7,16 +7,16 @@ executable('Hyprland', src,
server_protos, server_protos,
dependency('wayland-server'), dependency('wayland-server'),
dependency('wayland-client'), dependency('wayland-client'),
@ -65,7 +57,8 @@ index 8430f597..da041dd9 100644
+ dependency('xcb', required: get_option('xwayland')), + dependency('xcb', required: get_option('xwayland')),
backtrace_dep, backtrace_dep,
systemd_dep, systemd_dep,
udis86, - udis86,
+ dependency('udis86'),
2.39.3
dependency('pixman-1'),
dependency('gl', 'opengl'),

View File

@ -19,6 +19,7 @@ DEPENDS += " \
libdrm \ libdrm \
libxkbcommon \ libxkbcommon \
libinput \ libinput \
udis86 \
wlroots \ wlroots \
" "
@ -37,8 +38,8 @@ SRC_URI = " \
file://meson-build.patch \ file://meson-build.patch \
" "
SRCREV = "69439871e60eeb16993fd6044843d14d2191c9fb" SRCREV = "1b48642fd15c433c53876f1b933dcd46265caf8f"
PV = "0.29.1" PV = "0.30.0"
S = "${WORKDIR}/git" S = "${WORKDIR}/git"
inherit meson pkgconfig features_check inherit meson pkgconfig features_check
@ -50,4 +51,3 @@ PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,libxcb xcb-uti
PACKAGECONFIG[vulkan] = ",,vulkan-loader vulkan-headers glslang-native" PACKAGECONFIG[vulkan] = ",,vulkan-loader vulkan-headers glslang-native"
FILES:${PN} += "${datadir}" FILES:${PN} += "${datadir}"