gamescope: roll back to stable

This commit is contained in:
Markus Volk 2024-04-14 18:59:32 +02:00
parent 9c2470a7f9
commit d0ed62eafc
4 changed files with 24 additions and 47 deletions

View File

@ -10,18 +10,18 @@ manually add it to CXXFLAGS
1 file changed, 2 insertions(+), 2 deletions(-) 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/meson.build b/src/meson.build diff --git a/src/meson.build b/src/meson.build
index 7f7e793..c61077f 100644 index d3dec0d..da0affe 100644
--- a/src/meson.build --- a/src/meson.build
+++ b/src/meson.build +++ b/src/meson.build
@@ -20,7 +20,7 @@ cap_dep = dependency('libcap', required: get_option('rt_cap')) @@ -18,7 +18,7 @@ cap_dep = dependency('libcap', required: false)
epoll_dep = dependency('epoll-shim', required: false) epoll_dep = dependency('epoll-shim', required: false)
glm_dep = dependency('glm') glm_dep = dependency('glm')
sdl_dep = dependency('SDL2', required: get_option('sdl2_backend')) sdl_dep = dependency('SDL2')
-stb_dep = dependency('stb') -stb_dep = dependency('stb')
+stb_dep = dependency('stb', required: false) +stb_dep = dependency('stb', required: false)
avif_dep = dependency('libavif', version: '>=1.0.0', required: get_option('avif_screenshots'))
wlroots_dep = dependency( wlroots_dep = dependency(
'wlroots',
-- --
2.43.0 2.43.0

View File

@ -1,25 +0,0 @@
From 7a9090bff4fb65caf7973b359124a6572a8ea41d Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Mon, 12 Feb 2024 18:50:31 +0100
Subject: [PATCH] meson.build: dont force subprojects
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
meson.build | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
index 7af6884..eab837a 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,6 @@ project(
default_options: [
'cpp_std=c++20',
'warning_level=2',
- 'force_fallback_for=wlroots,libliftoff,vkroots',
],
)
--
2.43.0

View File

@ -11,18 +11,18 @@ Signed-off-by: Markus Volk <f_l_k@t-online.de>
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build diff --git a/meson.build b/meson.build
index 04bd472..345a2a7 100644 index 7af6884..e67146a 100644
--- a/meson.build --- a/meson.build
+++ b/meson.build +++ b/meson.build
@@ -67,7 +67,7 @@ add_project_arguments( @@ -62,7 +62,7 @@ endif
add_project_arguments(
if hwdata_dep.found() '-DHAVE_PIPEWIRE=@0@'.format(pipewire_dep.found().to_int()),
add_project_arguments( '-DHAVE_OPENVR=@0@'.format(openvr_dep.found().to_int()),
- '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('pkgdatadir') / 'pnp.ids'), - '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('pkgdatadir') / 'pnp.ids'),
+ '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('datadir') / 'hwdata' / 'pnp.ids'), + '-DHWDATA_PNP_IDS="@0@"'.format(hwdata_dep.get_variable('datadir') / 'hwdata' / 'pnp.ids'),
language: 'cpp', language: 'cpp',
) )
else
-- --
2.43.0 2.43.0

View File

@ -11,7 +11,9 @@ DEPENDS += " \
glslang-native \ glslang-native \
hwdata \ hwdata \
libdisplay-info \ libdisplay-info \
libinput \
libliftoff \ libliftoff \
libsdl2 \
libdrm \ libdrm \
libx11\ libx11\
libxcomposite \ libxcomposite \
@ -21,34 +23,34 @@ DEPENDS += " \
libxmu \ libxmu \
libxrender \ libxrender \
libxtst \ libxtst \
seatd \
stb \ stb \
vulkan-headers \ vulkan-headers \
wayland \ wayland \
wayland-native \ wayland-native \
wayland-protocols \ wayland-protocols \
wlroots-0.17 \ xcb-util-wm \
xwayland \
" "
RDEPENDS:${PN} = "xwayland hwdata" RDEPENDS:${PN} = "xwayland hwdata"
CXXFLAGS:append = " -I${STAGING_INCDIR}/stb" CXXFLAGS:append = " -I${STAGING_INCDIR}/stb"
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl pipewire', d)} rt_cap avif_screenshots openvr" PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl pipewire', d)} openvr"
PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=false" PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=false"
PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire" PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
PACKAGECONFIG[opengl] = ",,mesa-glut" PACKAGECONFIG[opengl] = ",,mesa-glut"
PACKAGECONFIG[avif_screenshots] = "-Davif_screenshots=enabled,-Davif_screenshots=disabled,libavif"
PACKAGECONFIG[rt_cap] = "-Drt_cap=enabled,-Drt_cap=disabled,libcap"
PACKAGECONFIG[sdl2_backend] = "-Dsdl2_backend=enabled,-Dsdl2_backend=disabled,libsdl2"
SRC_URI = " \
gitsm://github.com/ValveSoftware/gamescope.git;branch=master;protocol=https \ SRC_URI = " \
file://0001-meson.build-dont-fail-if-stb-is-not-found.patch \ gitsm://github.com/ValveSoftware/gamescope.git;branch=jupiter-3.5;protocol=https \
file://0001-meson.build-dont-leak-buildpath.patch \ file://0001-meson.build-dont-leak-buildpath.patch \
file://0001-meson.build-dont-force-subprojects.patch\ file://0001-meson.build-dont-fail-if-stb-is-not-found.patch \
" "
SRCREV = "d0d23c4c3010c81add1bd90cbe478ce4a386e28d"
PV = "3.14.2" SRCREV = "c59b09dbc0c100f604ae603c5f0026c42c62d49c"
PV = "3.13.16.9"
S = "${WORKDIR}/git" S = "${WORKDIR}/git"