mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-12-27 05:58:22 +01:00
hyprland: update
This commit is contained in:
parent
71ca5a4501
commit
c943ed7233
@ -1,23 +0,0 @@
|
|||||||
From 778bdf730ff957521cc114d170bc82fc44b8be22 Mon Sep 17 00:00:00 2001
|
|
||||||
From: gnusenpai <pspslimboy98@gmail.com>
|
|
||||||
Date: Mon, 2 Oct 2023 09:51:15 +0000
|
|
||||||
Subject: [PATCH 1/7] internal: Add GTK portal as fallback (#3469)
|
|
||||||
|
|
||||||
needed for XDP 1.17+ since the fallback to the GTK portal was removed
|
|
||||||
---
|
|
||||||
assets/hyprland-portals.conf | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/assets/hyprland-portals.conf b/assets/hyprland-portals.conf
|
|
||||||
index 2ec1f0de..da8b5db0 100644
|
|
||||||
--- a/assets/hyprland-portals.conf
|
|
||||||
+++ b/assets/hyprland-portals.conf
|
|
||||||
@@ -1,2 +1,2 @@
|
|
||||||
[preferred]
|
|
||||||
-default=hyprland
|
|
||||||
\ No newline at end of file
|
|
||||||
+default=hyprland;gtk
|
|
||||||
\ No newline at end of file
|
|
||||||
--
|
|
||||||
2.42.0
|
|
||||||
|
|
@ -1,23 +1,21 @@
|
|||||||
|
From 19e0c04a57bfb3677caf1ac8c22527b066666a95 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Markus Volk <f_l_k@t-online.de>
|
||||||
|
Date: Sun, 23 Jul 2023 10:19:54 +0200
|
||||||
|
Subject: [PATCH] hyprland: update
|
||||||
|
|
||||||
|
---
|
||||||
|
meson.build | 17 +----------------
|
||||||
|
src/meson.build | 6 +++---
|
||||||
|
2 files changed, 4 insertions(+), 19 deletions(-)
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
diff --git a/meson.build b/meson.build
|
||||||
index f3802553..6a924a79 100644
|
index 1d2c7f9f..c5ef4e67 100644
|
||||||
--- a/meson.build
|
--- a/meson.build
|
||||||
+++ b/meson.build
|
+++ b/meson.build
|
||||||
@@ -21,9 +21,9 @@ else
|
@@ -33,20 +33,7 @@ if cpp_compiler.check_header('execinfo.h')
|
||||||
|
add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
|
||||||
endif
|
endif
|
||||||
|
|
||||||
GIT_BRANCH = run_command('git', 'rev-parse', '--abbrev-ref', 'HEAD', check: false).stdout().strip()
|
|
||||||
-GIT_COMMIT_HASH = run_command('git', 'rev-parse', 'HEAD', check: false).stdout().strip()
|
|
||||||
+GIT_COMMIT_HASH = '@GIT_COMMIT_HASH@'
|
|
||||||
GIT_COMMIT_MESSAGE = run_command('sh', '-c', 'git show | head -n 5 | tail -n 1', check: false).stdout().strip()
|
|
||||||
-GIT_DIRTY = run_command('sh', '-c', 'git diff-index --quiet HEAD -- || echo "dirty"', check: false).stdout().strip()
|
|
||||||
+GIT_DIRTY = '@GIT_DIRTY@'
|
|
||||||
|
|
||||||
add_project_arguments(
|
|
||||||
[
|
|
||||||
@@ -39,21 +39,8 @@ add_project_arguments(
|
|
||||||
],
|
|
||||||
language: 'cpp')
|
|
||||||
|
|
||||||
-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
|
-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
|
||||||
-have_xwlr = wlroots.get_variable('features').get('xwayland')
|
-have_xwlr = wlroots.get_variable('features').get('xwayland')
|
||||||
-xcb_dep = dependency('xcb', required: get_option('xwayland'))
|
-xcb_dep = dependency('xcb', required: get_option('xwayland'))
|
||||||
@ -32,17 +30,15 @@ index f3802553..6a924a79 100644
|
|||||||
-have_xwayland = xcb_dep.found() and have_xwlr
|
-have_xwayland = xcb_dep.found() and have_xwlr
|
||||||
-
|
-
|
||||||
-if not have_xwayland
|
-if not have_xwayland
|
||||||
- add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
|
|
||||||
+if get_option('xwayland').disabled()
|
+if get_option('xwayland').disabled()
|
||||||
+ add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
|
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
|
||||||
endif
|
endif
|
||||||
|
|
||||||
backtrace_dep = cpp_compiler.find_library('execinfo', required: false)
|
|
||||||
diff --git a/src/meson.build b/src/meson.build
|
diff --git a/src/meson.build b/src/meson.build
|
||||||
index 7b658d31..60aa4057 100644
|
index 0af864b9..38723b8c 100644
|
||||||
--- a/src/meson.build
|
--- a/src/meson.build
|
||||||
+++ b/src/meson.build
|
+++ b/src/meson.build
|
||||||
@@ -7,16 +7,16 @@ executable('Hyprland', src,
|
@@ -9,16 +9,16 @@ executable('Hyprland', src,
|
||||||
server_protos,
|
server_protos,
|
||||||
dependency('wayland-server'),
|
dependency('wayland-server'),
|
||||||
dependency('wayland-client'),
|
dependency('wayland-client'),
|
||||||
@ -62,3 +58,4 @@ index 7b658d31..60aa4057 100644
|
|||||||
|
|
||||||
dependency('pixman-1'),
|
dependency('pixman-1'),
|
||||||
dependency('gl', 'opengl'),
|
dependency('gl', 'opengl'),
|
||||||
|
|
||||||
|
@ -36,11 +36,10 @@ RRECOMMENDS:${PN} ?= " \
|
|||||||
SRC_URI = " \
|
SRC_URI = " \
|
||||||
gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=main \
|
gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=main \
|
||||||
file://meson-build.patch \
|
file://meson-build.patch \
|
||||||
file://0001-internal-Add-GTK-portal-as-fallback-3469.patch \
|
|
||||||
"
|
"
|
||||||
|
|
||||||
SRCREV = "1b48642fd15c433c53876f1b933dcd46265caf8f"
|
SRCREV = "9afdd61adeaf413afbe853dbc5fdf6853c8bde21"
|
||||||
PV = "0.30.0"
|
PV = "0.32.3"
|
||||||
S = "${WORKDIR}/git"
|
S = "${WORKDIR}/git"
|
||||||
|
|
||||||
inherit meson pkgconfig features_check
|
inherit meson pkgconfig features_check
|
||||||
|
Loading…
Reference in New Issue
Block a user