hyprland: update

build with shared wlroots instead of using subproject
https://github.com/hyprwm/Hyprland/blob/main/nix/patches/meson-build.patch
This commit is contained in:
Markus Volk 2023-07-23 10:19:54 +02:00
parent 5ce71c1738
commit c245f10e5a
2 changed files with 78 additions and 9 deletions

View File

@ -0,0 +1,71 @@
From 6218794fafe27f74770d616626d9af570dabfbf6 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Sat, 22 Jul 2023 00:55:42 +0200
Subject: [PATCH] meson-build
---
meson.build | 15 +++------------
1 file changed, 3 insertions(+), 12 deletions(-)
diff --git a/meson.build b/meson.build
index 6a94dee6..3049e1ce 100644
--- a/meson.build
+++ b/meson.build
@@ -21,9 +21,9 @@ else
endif
GIT_BRANCH = run_command('git', 'rev-parse', '--abbrev-ref', 'HEAD', check: false).stdout().strip()
-GIT_COMMIT_HASH = run_command('git', 'rev-parse', 'HEAD', check: false).stdout().strip()
+GIT_COMMIT_HASH = '@GIT_COMMIT_HASH@'
GIT_COMMIT_MESSAGE = run_command('sh', '-c', 'git show | head -n 5 | tail -n 1', check: false).stdout().strip()
-GIT_DIRTY = run_command('sh', '-c', 'git diff-index --quiet HEAD -- || echo "dirty"', check: false).stdout().strip()
+GIT_DIRTY = '@GIT_DIRTY@'
add_project_arguments(
[
@@ -39,20 +39,11 @@ add_project_arguments(
],
language: 'cpp')
-wlroots = subproject('wlroots', default_options: ['examples=false'])
-have_xwlr = wlroots.get_variable('features').get('xwayland')
-xcb_dep = dependency('xcb', required: get_option('xwayland'))
-
cmake = import('cmake')
udis = cmake.subproject('udis86')
udis86 = udis.dependency('libudis86')
-if get_option('xwayland').enabled() and not have_xwlr
- error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support')
-endif
-have_xwayland = xcb_dep.found() and have_xwlr
-
-if not have_xwayland
+if get_option('xwayland').disabled()
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif
-- diff --git a/src/meson.build b/src/meson.build
index 8430f597..da041dd9 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -8,13 +8,13 @@ executable('Hyprland', src,
server_protos,
dependency('wayland-server'),
dependency('wayland-client'),
- wlroots.get_variable('wlroots'),
+ dependency('wlroots'),
dependency('cairo'),
dependency('libdrm'),
dependency('egl'),
dependency('xkbcommon'),
dependency('libinput'),
- xcb_dep,
+ dependency('xcb', required: get_option('xwayland')),
backtrace_dep,
systemd_dep,
udis86,
2.39.3

View File

@ -10,21 +10,16 @@ REQUIRED_DISTRO_FEATURES = "wayland opengl"
DEPENDS += " \
virtual/egl \
virtual/libgles2 \
virtual/libgbm \
cairo \
wayland \
wayland-native \
wayland-protocols \
jq-native \
libdisplay-info \
pango \
pixman \
libdrm \
libxkbcommon \
seatd \
hwdata-native \
libinput \
wlroots \
"
RDEPENDS:${PN} ?= ""
@ -40,10 +35,13 @@ RRECOMMENDS:${PN} ?= " \
hyprland-hyprbars \
"
SRC_URI = "gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=main"
SRC_URI = " \
gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=main \
file://meson-build.patch \
"
SRCREV = "5e577acf516b80173f695a458c2cc188a4d64560"
PV = "0.27.0"
SRCREV = "b08b72358ad549fd066e5be0fc3aa4c9df367607"
PV = "0.27.2"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check