mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-19 20:08:27 +01:00
libgnome-volume-control: add recipe
This is intended to be used as subproject. Build a package nevertheless, because phosh only supports inappropriate wrap file
This commit is contained in:
parent
5ff25ca8eb
commit
b411363b27
@ -0,0 +1,39 @@
|
|||||||
|
From db03d3455c9db082c373318c08f2377c03a62e99 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Markus Volk <f_l_k@t-online.de>
|
||||||
|
Date: Tue, 20 Aug 2024 12:22:55 +0200
|
||||||
|
Subject: [PATCH] meson.build: allow shared build
|
||||||
|
|
||||||
|
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||||
|
---
|
||||||
|
meson.build | 6 +++++-
|
||||||
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index a1a2af5..97f43c1 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -3,12 +3,14 @@ project('gvc', 'c',
|
||||||
|
default_options: ['static=true']
|
||||||
|
)
|
||||||
|
|
||||||
|
-assert(meson.is_subproject(), 'This project is only intended to be used as a subproject!')
|
||||||
|
+#assert(meson.is_subproject(), 'This project is only intended to be used as a subproject!')
|
||||||
|
|
||||||
|
gnome = import('gnome')
|
||||||
|
|
||||||
|
pkglibdir = get_option('pkglibdir')
|
||||||
|
pkgdatadir = get_option('pkgdatadir')
|
||||||
|
+pkgconfig = import ('pkgconfig')
|
||||||
|
+
|
||||||
|
|
||||||
|
cdata = configuration_data()
|
||||||
|
cdata.set_quoted('GETTEXT_PACKAGE', get_option('package_name'))
|
||||||
|
@@ -135,3 +137,5 @@ configure_file(
|
||||||
|
output: 'config.h',
|
||||||
|
configuration: cdata
|
||||||
|
)
|
||||||
|
+
|
||||||
|
+pkgconfig.generate(libgvc)
|
||||||
|
--
|
||||||
|
2.45.2
|
||||||
|
|
@ -0,0 +1,30 @@
|
|||||||
|
SUMMARY = "libgnome-volume-control is a copy library"
|
||||||
|
HOMEPAGE = "http://www.gimp.org"
|
||||||
|
SECTION = "graphics"
|
||||||
|
LICENSE = "GPL-2.0-only"
|
||||||
|
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
|
||||||
|
|
||||||
|
DEPENDS = " \
|
||||||
|
glib-2.0 \
|
||||||
|
pulseaudio \
|
||||||
|
"
|
||||||
|
|
||||||
|
inherit meson pkgconfig
|
||||||
|
|
||||||
|
SRC_URI = " \
|
||||||
|
git://gitlab.gnome.org/GNOME/libgnome-volume-control.git;protocol=https;branch=master \
|
||||||
|
file://0001-build-as-package.patch \
|
||||||
|
"
|
||||||
|
|
||||||
|
S = "${WORKDIR}/git"
|
||||||
|
SRCREV = "5f9768a2eac29c1ed56f1fbb449a77a3523683b6"
|
||||||
|
|
||||||
|
do_install:append() {
|
||||||
|
install -d ${D}${includedir}
|
||||||
|
install -m 0644 ${B}/libgvc.a ${D}${libdir}
|
||||||
|
cp -rf ${B}/libgvc.a.p ${D}${libdir}
|
||||||
|
install -m 0644 ${S}/*.h ${D}${includedir}
|
||||||
|
install -m 0644 ${B}/*.h ${D}${includedir}
|
||||||
|
}
|
||||||
|
|
||||||
|
FILES:${PN} += "${libdir}/libgvc.a.p"
|
Loading…
Reference in New Issue
Block a user