mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2025-02-13 07:32:46 +01:00
gamescope: update
Developer tries hard to build things statically. Rework accordingly
This commit is contained in:
parent
4e675238de
commit
8d73d44880
@ -1,25 +0,0 @@
|
|||||||
From 7a9090bff4fb65caf7973b359124a6572a8ea41d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Markus Volk <f_l_k@t-online.de>
|
|
||||||
Date: Mon, 12 Feb 2024 18:50:31 +0100
|
|
||||||
Subject: [PATCH] meson.build: dont force subprojects
|
|
||||||
|
|
||||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
|
||||||
---
|
|
||||||
meson.build | 3 +--
|
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index 7af6884..eab837a 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -6,7 +6,6 @@ project(
|
|
||||||
default_options: [
|
|
||||||
'cpp_std=c++20',
|
|
||||||
'warning_level=2',
|
|
||||||
- 'force_fallback_for=wlroots,libliftoff,vkroots',
|
|
||||||
],
|
|
||||||
)
|
|
||||||
|
|
||||||
--
|
|
||||||
2.43.0
|
|
||||||
|
|
@ -10,9 +10,10 @@ DEPENDS += " \
|
|||||||
glm \
|
glm \
|
||||||
glslang-native \
|
glslang-native \
|
||||||
hwdata \
|
hwdata \
|
||||||
|
libei \
|
||||||
|
libdecor \
|
||||||
libdisplay-info \
|
libdisplay-info \
|
||||||
libliftoff \
|
libinput \
|
||||||
libdrm \
|
|
||||||
libx11\
|
libx11\
|
||||||
libxcomposite \
|
libxcomposite \
|
||||||
libxcursor \
|
libxcursor \
|
||||||
@ -21,34 +22,36 @@ DEPENDS += " \
|
|||||||
libxmu \
|
libxmu \
|
||||||
libxrender \
|
libxrender \
|
||||||
libxtst \
|
libxtst \
|
||||||
|
seatd \
|
||||||
stb \
|
stb \
|
||||||
vulkan-headers \
|
vulkan-headers \
|
||||||
wayland \
|
wayland \
|
||||||
wayland-native \
|
wayland-native \
|
||||||
wayland-protocols \
|
wayland-protocols \
|
||||||
wlroots-0.17 \
|
xcb-util-wm \
|
||||||
|
xwayland \
|
||||||
"
|
"
|
||||||
|
|
||||||
RDEPENDS:${PN} = "xwayland hwdata"
|
RDEPENDS:${PN} = "xwayland hwdata"
|
||||||
|
|
||||||
CXXFLAGS:append = " -I${STAGING_INCDIR}/stb"
|
CXXFLAGS:append = " -I${STAGING_INCDIR}/stb"
|
||||||
|
|
||||||
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl pipewire', d)} rt_cap avif_screenshots openvr"
|
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl pipewire', d)} rt_cap avif_screenshots openvr sdl2_backend drm_backend"
|
||||||
PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=false"
|
PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=false"
|
||||||
PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
|
PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
|
||||||
PACKAGECONFIG[opengl] = ",,mesa-glut"
|
PACKAGECONFIG[opengl] = ",,mesa-glut"
|
||||||
PACKAGECONFIG[avif_screenshots] = "-Davif_screenshots=enabled,-Davif_screenshots=disabled,libavif"
|
PACKAGECONFIG[avif_screenshots] = "-Davif_screenshots=enabled,-Davif_screenshots=disabled,libavif"
|
||||||
PACKAGECONFIG[rt_cap] = "-Drt_cap=enabled,-Drt_cap=disabled,libcap"
|
PACKAGECONFIG[rt_cap] = "-Drt_cap=enabled,-Drt_cap=disabled,libcap"
|
||||||
PACKAGECONFIG[sdl2_backend] = "-Dsdl2_backend=enabled,-Dsdl2_backend=disabled,libsdl2"
|
PACKAGECONFIG[sdl2_backend] = "-Dsdl2_backend=enabled,-Dsdl2_backend=disabled,libsdl2"
|
||||||
|
PACKAGECONFIG[drm_backend] = "-Ddrm_backend=enabled,-Ddrm_backend=disabled,libdrm"
|
||||||
|
|
||||||
SRC_URI = " \
|
SRC_URI = " \
|
||||||
gitsm://github.com/ValveSoftware/gamescope.git;branch=master;protocol=https \
|
gitsm://github.com/ValveSoftware/gamescope.git;branch=master;protocol=https \
|
||||||
file://0001-meson.build-dont-fail-if-stb-is-not-found.patch \
|
file://0001-meson.build-dont-fail-if-stb-is-not-found.patch \
|
||||||
file://0001-meson.build-dont-leak-buildpath.patch \
|
file://0001-meson.build-dont-leak-buildpath.patch \
|
||||||
file://0001-meson.build-dont-force-subprojects.patch\
|
|
||||||
"
|
"
|
||||||
SRCREV = "d0d23c4c3010c81add1bd90cbe478ce4a386e28d"
|
SRCREV = "377365c8e77740055960724b8ff074c0b71782ae"
|
||||||
PV = "3.14.2"
|
PV = "3.14.3"
|
||||||
|
|
||||||
S = "${WORKDIR}/git"
|
S = "${WORKDIR}/git"
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user