hyprland: cleanup

This commit is contained in:
Markus Volk 2024-04-14 10:43:15 +02:00
parent 6a0ed0f3cd
commit 7ba60e097d
5 changed files with 5 additions and 190 deletions

View File

@ -1,52 +0,0 @@
SUMMARY = "A Wayland WM"
HOMEPAGE = "https://hyprland.org/"
SECTION = "graphics"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a08367f3a4cd5301ba8b88eded36b8fd"
REQUIRED_DISTRO_FEATURES = "wayland opengl"
DEPENDS += " \
virtual/egl \
cairo \
wayland \
wayland-native \
jq-native \
pango \
pixman \
libdrm \
libxkbcommon \
libinput \
udis86 \
wlroots-0.17 \
"
RRECOMMENDS:${PN} ?= " \
foot \
jq \
grim \
slurp \
wl-clipboard \
hyprland-contrib \
"
SRC_URI = " \
gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=main \
file://meson-build.patch \
"
SRCREV = "9afdd61adeaf413afbe853dbc5fdf6853c8bde21"
PV = "0.32.3"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd xwayland', d)}"
PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled"
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,libxcb xcb-util-wm xcb-util-renderutil xwayland,xwayland"
PACKAGECONFIG[legacy_renderer] = "-Dlegacy_renderer=enabled,-Dlegacy_renderer=disabled"
FILES:${PN} += "${datadir}"

View File

@ -1,60 +0,0 @@
From 19e0c04a57bfb3677caf1ac8c22527b066666a95 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Sun, 23 Jul 2023 10:19:54 +0200
Subject: [PATCH] hyprland: update
---
meson.build | 17 +----------------
src/meson.build | 6 +++---
2 files changed, 4 insertions(+), 19 deletions(-)
diff --git a/meson.build b/meson.build
index 1d2c7f9f..c5ef4e67 100644
--- a/meson.build
+++ b/meson.build
@@ -33,20 +33,7 @@ if cpp_compiler.check_header('execinfo.h')
add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
endif
-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
-have_xwlr = wlroots.get_variable('features').get('xwayland')
-xcb_dep = dependency('xcb', required: get_option('xwayland'))
-
-cmake = import('cmake')
-udis = cmake.subproject('udis86')
-udis86 = udis.dependency('libudis86')
-
-if get_option('xwayland').enabled() and not have_xwlr
- error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support')
-endif
-have_xwayland = xcb_dep.found() and have_xwlr
-
-if not have_xwayland
+if get_option('xwayland').disabled()
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif
diff --git a/src/meson.build b/src/meson.build
index 0af864b9..38723b8c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -9,16 +9,16 @@ executable('Hyprland', src,
server_protos,
dependency('wayland-server'),
dependency('wayland-client'),
- wlroots.get_variable('wlroots'),
+ dependency('wlroots'),
dependency('cairo'),
dependency('libdrm'),
dependency('egl'),
dependency('xkbcommon'),
dependency('libinput'),
- xcb_dep,
+ dependency('xcb', required: get_option('xwayland')),
backtrace_dep,
systemd_dep,
- udis86,
+ dependency('udis86'),
dependency('pixman-1'),
dependency('gl', 'opengl'),

View File

@ -12,17 +12,19 @@ DEPENDS += " \
hyprcursor \ hyprcursor \
hyprlang \ hyprlang \
jq-native \ jq-native \
hwdata-native \
libdisplay-info \
libliftoff \
libdrm \ libdrm \
libinput \ libinput \
libxkbcommon \ libxkbcommon \
pango \ pango \
pixman \ pixman \
seatd \
tomlplusplus \ tomlplusplus \
udis86 \
virtual/egl \ virtual/egl \
wayland \ wayland \
wayland-native \ wayland-native \
wlroots \
" "
RRECOMMENDS:${PN} ?= " \ RRECOMMENDS:${PN} ?= " \
@ -34,10 +36,7 @@ RRECOMMENDS:${PN} ?= " \
hyprland-contrib \ hyprland-contrib \
" "
SRC_URI = " \ SRC_URI = "gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=v0.38.1-b"
gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=v0.38.1-b \
file://meson-build.patch \
"
SRCREV = "360ede79d124ffdeebbe8401f1ac4bc0dbec2c91" SRCREV = "360ede79d124ffdeebbe8401f1ac4bc0dbec2c91"
S = "${WORKDIR}/git" S = "${WORKDIR}/git"

View File

@ -1,71 +0,0 @@
From 596cf2f2e1cbe68ce5673711d84cbfd576d40db1 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Sun, 23 Jul 2023 10:19:54 +0200
Subject: [PATCH] hyprland: update
---
meson.build | 17 +----------------
src/meson.build | 6 +++---
2 files changed, 4 insertions(+), 19 deletions(-)
diff --git a/meson.build b/meson.build
index 81d6e403..04503a3c 100644
--- a/meson.build
+++ b/meson.build
@@ -33,20 +33,7 @@ if cpp_compiler.check_header('execinfo.h')
add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
endif
-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
-have_xwlr = wlroots.get_variable('features').get('xwayland')
-xcb_dep = dependency('xcb', required: get_option('xwayland'))
-
-cmake = import('cmake')
-udis = cmake.subproject('udis86')
-udis86 = udis.dependency('libudis86')
-
-if get_option('xwayland').enabled() and not have_xwlr
- error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support')
-endif
-have_xwayland = xcb_dep.found() and have_xwlr
-
-if not have_xwayland
+if get_option('xwayland').disabled()
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
endif
@@ -69,8 +56,6 @@ if get_option('buildtype') == 'debug'
add_project_arguments('-DHYPRLAND_DEBUG', language: 'cpp')
endif
-version_h = run_command('sh', '-c', 'scripts/generateVersion.sh')
-
globber = run_command('find', 'src', '-name', '*.h*', check: true)
headers = globber.stdout().strip().split('\n')
foreach file : headers
diff --git a/src/meson.build b/src/meson.build
index 59771fcf..a77349c4 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -9,7 +9,7 @@ executable('Hyprland', src,
server_protos,
dependency('wayland-server'),
dependency('wayland-client'),
- wlroots.get_variable('wlroots'),
+ dependency('wlroots'),
dependency('cairo'),
dependency('hyprcursor'),
dependency('hyprlang', version: '>= 0.3.2'),
@@ -17,10 +17,10 @@ executable('Hyprland', src,
dependency('egl'),
dependency('xkbcommon'),
dependency('libinput'),
- xcb_dep,
+ dependency('xcb', required: get_option('xwayland')),
backtrace_dep,
systemd_dep,
- udis86,
+ dependency('udis86'),
dependency('pixman-1'),
dependency('gl', 'opengl'),

View File

@ -22,7 +22,6 @@ DEPENDS += " \
pixman \ pixman \
seatd \ seatd \
tomlplusplus \ tomlplusplus \
udis86 \
virtual/egl \ virtual/egl \
wayland \ wayland \
wayland-native \ wayland-native \