mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-20 04:18:25 +01:00
hyprland: update
This commit is contained in:
parent
3094f63f5a
commit
74da42db88
52
recipes-wlroots/hyprland/hyprland-0.32.3.bb
Normal file
52
recipes-wlroots/hyprland/hyprland-0.32.3.bb
Normal file
@ -0,0 +1,52 @@
|
||||
|
||||
SUMMARY = "A Wayland WM"
|
||||
HOMEPAGE = "https://hyprland.org/"
|
||||
SECTION = "graphics"
|
||||
LICENSE = "BSD-3-Clause"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=a08367f3a4cd5301ba8b88eded36b8fd"
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland opengl"
|
||||
|
||||
DEPENDS += " \
|
||||
virtual/egl \
|
||||
cairo \
|
||||
wayland \
|
||||
wayland-native \
|
||||
jq-native \
|
||||
pango \
|
||||
pixman \
|
||||
libdrm \
|
||||
libxkbcommon \
|
||||
libinput \
|
||||
udis86 \
|
||||
wlroots-0.17 \
|
||||
"
|
||||
|
||||
RRECOMMENDS:${PN} ?= " \
|
||||
foot \
|
||||
jq \
|
||||
grim \
|
||||
slurp \
|
||||
wl-clipboard \
|
||||
hyprland-contrib \
|
||||
"
|
||||
|
||||
SRC_URI = " \
|
||||
gitsm://github.com/hyprwm/Hyprland.git;protocol=https;branch=main \
|
||||
file://meson-build.patch \
|
||||
"
|
||||
|
||||
SRCREV = "9afdd61adeaf413afbe853dbc5fdf6853c8bde21"
|
||||
PV = "0.32.3"
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
||||
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd xwayland', d)}"
|
||||
|
||||
PACKAGECONFIG[systemd] = "-Dsystemd=enabled,Dsystemd=disabled"
|
||||
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,libxcb xcb-util-wm xcb-util-renderutil xwayland,xwayland"
|
||||
PACKAGECONFIG[legacy_renderer] = "-Dlegacy_renderer=enabled,-Dlegacy_renderer=disabled"
|
||||
|
||||
FILES:${PN} += "${datadir}"
|
60
recipes-wlroots/hyprland/hyprland-0.32.3/meson-build.patch
Normal file
60
recipes-wlroots/hyprland/hyprland-0.32.3/meson-build.patch
Normal file
@ -0,0 +1,60 @@
|
||||
From 19e0c04a57bfb3677caf1ac8c22527b066666a95 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Sun, 23 Jul 2023 10:19:54 +0200
|
||||
Subject: [PATCH] hyprland: update
|
||||
|
||||
---
|
||||
meson.build | 17 +----------------
|
||||
src/meson.build | 6 +++---
|
||||
2 files changed, 4 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 1d2c7f9f..c5ef4e67 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -33,20 +33,7 @@ if cpp_compiler.check_header('execinfo.h')
|
||||
add_project_arguments('-DHAS_EXECINFO', language: 'cpp')
|
||||
endif
|
||||
|
||||
-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
|
||||
-have_xwlr = wlroots.get_variable('features').get('xwayland')
|
||||
-xcb_dep = dependency('xcb', required: get_option('xwayland'))
|
||||
-
|
||||
-cmake = import('cmake')
|
||||
-udis = cmake.subproject('udis86')
|
||||
-udis86 = udis.dependency('libudis86')
|
||||
-
|
||||
-if get_option('xwayland').enabled() and not have_xwlr
|
||||
- error('Cannot enable Xwayland in Hyprland: wlroots has been built without Xwayland support')
|
||||
-endif
|
||||
-have_xwayland = xcb_dep.found() and have_xwlr
|
||||
-
|
||||
-if not have_xwayland
|
||||
+if get_option('xwayland').disabled()
|
||||
add_project_arguments('-DNO_XWAYLAND', language: 'cpp')
|
||||
endif
|
||||
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index 0af864b9..38723b8c 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -9,16 +9,16 @@ executable('Hyprland', src,
|
||||
server_protos,
|
||||
dependency('wayland-server'),
|
||||
dependency('wayland-client'),
|
||||
- wlroots.get_variable('wlroots'),
|
||||
+ dependency('wlroots'),
|
||||
dependency('cairo'),
|
||||
dependency('libdrm'),
|
||||
dependency('egl'),
|
||||
dependency('xkbcommon'),
|
||||
dependency('libinput'),
|
||||
- xcb_dep,
|
||||
+ dependency('xcb', required: get_option('xwayland')),
|
||||
backtrace_dep,
|
||||
systemd_dep,
|
||||
- udis86,
|
||||
+ dependency('udis86'),
|
||||
|
||||
dependency('pixman-1'),
|
||||
dependency('gl', 'opengl'),
|
@ -37,7 +37,7 @@ SRC_URI = " \
|
||||
file://meson-build.patch \
|
||||
"
|
||||
|
||||
SRCREV = "f39a6ca17c3abd9ce472e4cf5fd96df462969c4f"
|
||||
SRCREV = "512a59731b2e579b66325d0e9ce770919eecd685"
|
||||
PV = "0.32.3"
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user