mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-20 04:18:25 +01:00
gmobile: update
This commit is contained in:
parent
79586655e8
commit
610d93b205
@ -1,53 +0,0 @@
|
|||||||
From a9c5d3add6550e27636de3ef86d6eb8bad41874d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Markus Volk <f_l_k@t-online.de>
|
|
||||||
Date: Tue, 15 Aug 2023 07:36:31 +0200
|
|
||||||
Subject: [PATCH] meson.build: add a pkgconfig .pc file
|
|
||||||
|
|
||||||
- fix version
|
|
||||||
- build shared lib and install
|
|
||||||
- install headers
|
|
||||||
|
|
||||||
Upstream-Status: Inappropriate
|
|
||||||
|
|
||||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
|
||||||
---
|
|
||||||
meson.build | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index e9f6c62..7e94496 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -99,3 +99,7 @@ summary({
|
|
||||||
bool_yn: true,
|
|
||||||
section: 'Build',
|
|
||||||
)
|
|
||||||
+
|
|
||||||
+install_headers('src/gmobile.h' , 'src/gm-cutout.h', 'src/gm-device-info.h', 'src/gm-device-tree.h', 'src/gm-display-panel.h', 'src/gm-error.h', 'src/gm-main.h', 'src/gm-timeout.h', 'src/gm-rect.h')
|
|
||||||
+pkg = import('pkgconfig')
|
|
||||||
+pkg.generate(gm_lib)
|
|
||||||
diff --git a/src/meson.build b/src/meson.build
|
|
||||||
index ee98a39..8d8fd7d 100644
|
|
||||||
--- a/src/meson.build
|
|
||||||
+++ b/src/meson.build
|
|
||||||
@@ -37,12 +37,15 @@ gm_c_args = [
|
|
||||||
'-DG_LOG_DOMAIN="gmobile"',
|
|
||||||
]
|
|
||||||
|
|
||||||
-gm_lib = static_library(
|
|
||||||
+gm_lib = shared_library(
|
|
||||||
'gmobile',
|
|
||||||
gm_sources,
|
|
||||||
include_directories: root_inc,
|
|
||||||
c_args: gm_c_args,
|
|
||||||
- dependencies: gm_deps)
|
|
||||||
+ dependencies: gm_deps,
|
|
||||||
+ version: meson.project_version(),
|
|
||||||
+ install: true,
|
|
||||||
+)
|
|
||||||
|
|
||||||
gmobile_dep = declare_dependency(
|
|
||||||
include_directories: [root_inc, include_directories('.')],
|
|
||||||
--
|
|
||||||
2.41.0
|
|
||||||
|
|
@ -2,17 +2,14 @@ SUMMARY = "gmobile carries some helpers for GNOME on mobile devices"
|
|||||||
LICENSE = "LGPL-2.1-or-later"
|
LICENSE = "LGPL-2.1-or-later"
|
||||||
LIC_FILES_CHKSUM = "file://src/gm-cutout.c;beginline=1;endline=5;md5=fdd1e77039fe571c0c9aa6280a7e7903"
|
LIC_FILES_CHKSUM = "file://src/gm-cutout.c;beginline=1;endline=5;md5=fdd1e77039fe571c0c9aa6280a7e7903"
|
||||||
|
|
||||||
inherit meson pkgconfig
|
inherit meson pkgconfig gobject-introspection
|
||||||
|
|
||||||
DEPENDS = "glib-2.0 json-glib"
|
DEPENDS = "glib-2.0 json-glib"
|
||||||
|
|
||||||
SRC_URI = " \
|
SRC_URI = "git://gitlab.gnome.org/World/Phosh/gmobile.git;protocol=https;branch=main"
|
||||||
git://gitlab.gnome.org/World/Phosh/gmobile.git;protocol=https;branch=main \
|
|
||||||
file://0001-meson.build-create-a-pkgconfig-.pc-file.patch \
|
|
||||||
"
|
|
||||||
S = "${WORKDIR}/git"
|
S = "${WORKDIR}/git"
|
||||||
SRCREV = "d5ed9ed758bf0deeb050d861fb08518295a42767"
|
SRCREV = "3f3a8c70f6106e00388075c77982876857b321d8"
|
||||||
PV = "0.0.4"
|
PV = "0.2.0"
|
||||||
|
|
||||||
do_install:append() {
|
do_install:append() {
|
||||||
install -m 0644 ${B}/gm-config.h ${D}${includedir}
|
install -m 0644 ${B}/gm-config.h ${D}${includedir}
|
||||||
|
Loading…
Reference in New Issue
Block a user