mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-19 20:08:27 +01:00
libcall-ui: add recipe
This is intended to be used as subproject. Build a package nevertheless, because phosh only supports inappropriate wrap file
This commit is contained in:
parent
8b1ab04d82
commit
5ff25ca8eb
@ -0,0 +1,32 @@
|
|||||||
|
From 02fee99a4be76b1db07f27cad68986061168e7e1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Markus Volk <f_l_k@t-online.de>
|
||||||
|
Date: Tue, 20 Aug 2024 11:57:39 +0200
|
||||||
|
Subject: [PATCH] build as package
|
||||||
|
|
||||||
|
---
|
||||||
|
meson.build | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index d33614b..d3e068d 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -19,6 +19,8 @@ systemduserdir = join_paths(systemddir, 'user')
|
||||||
|
|
||||||
|
root_inc = include_directories('.')
|
||||||
|
|
||||||
|
+pkgconfig = import ('pkgconfig')
|
||||||
|
+
|
||||||
|
cc = meson.get_compiler('c')
|
||||||
|
|
||||||
|
global_c_args = []
|
||||||
|
@@ -113,4 +115,6 @@ summary = [
|
||||||
|
'-----------',
|
||||||
|
]
|
||||||
|
|
||||||
|
+pkgconfig.generate(call_ui_lib)
|
||||||
|
+
|
||||||
|
message('\n'.join(summary))
|
||||||
|
--
|
||||||
|
2.45.2
|
||||||
|
|
30
recipes-extended/libcall-ui/libcall-ui_git.bb
Normal file
30
recipes-extended/libcall-ui/libcall-ui_git.bb
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
SUMMARY = "Libcall-ui carries common user interface parts for call handling. It is meant to be used as a git submodule."
|
||||||
|
HOMEPAGE = "https://gitlab.gnome.org/World/Phosh/libcall-ui"
|
||||||
|
LICENSE = "LGPL-2.1-only"
|
||||||
|
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
|
||||||
|
|
||||||
|
DEPENDS = "glib-2.0 libhandy gtk+3 callaudiod"
|
||||||
|
|
||||||
|
inherit meson pkgconfig gi-docgen gobject-introspection
|
||||||
|
|
||||||
|
SRC_URI = " \
|
||||||
|
git://gitlab.gnome.org/World/Phosh/libcall-ui.git;protocol=https;branch=libcall-ui-0.1.x \
|
||||||
|
file://0001-build-as-package.patch \
|
||||||
|
"
|
||||||
|
|
||||||
|
S = "${WORKDIR}/git"
|
||||||
|
PV = "0.1.3"
|
||||||
|
SRCREV = "60870e871e480e111e6a2fa50de67d1dd358d65a"
|
||||||
|
|
||||||
|
GIR_MESON_OPTION = ''
|
||||||
|
|
||||||
|
do_install:append() {
|
||||||
|
install -d ${D}${includedir}
|
||||||
|
install -m 0644 ${B}/src/libcall-ui.a ${D}${libdir}
|
||||||
|
cp -rf ${B}/src/libcall-ui.a.p ${D}${libdir}
|
||||||
|
install -m 0644 ${B}/cui-config.h ${D}${includedir}
|
||||||
|
install -m 0644 ${S}/src/*.h ${D}${includedir}
|
||||||
|
install -m 0644 ${B}/src/*.h ${D}${includedir}
|
||||||
|
}
|
||||||
|
|
||||||
|
FILES:${PN} += "${libdir}/libcall-ui.a.p"
|
Loading…
Reference in New Issue
Block a user