mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-12-26 05:28:23 +01:00
mako: add recipe
This commit is contained in:
parent
0709724a5f
commit
575ee7b8e6
@ -0,0 +1,26 @@
|
||||
From a8fa47e90bddccfe6dd9f267dd7a189793c8adca Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Mon, 2 Aug 2021 06:59:38 +0200
|
||||
Subject: [PATCH] meson.build: fix scdoc not to be found
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 180f0fb..0973213 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -130,7 +130,7 @@ configure_file(
|
||||
install_dir: datadir + '/dbus-1/services',
|
||||
)
|
||||
|
||||
-scdoc = dependency('scdoc', required: get_option('man-pages'), version: '>= 1.9.7')
|
||||
+scdoc = dependency('scdoc', native: true, required: get_option('man-pages'), version: '>= 1.9.7')
|
||||
|
||||
if scdoc.found()
|
||||
sh = find_program('sh')
|
||||
--
|
||||
2.25.1
|
||||
|
51
recipes-support/mako/mako_git.bb
Normal file
51
recipes-support/mako/mako_git.bb
Normal file
@ -0,0 +1,51 @@
|
||||
SUMMARY = "A lightweight notification daemon for Wayland."
|
||||
HOMEPAGE = "github.com/emersion/mako"
|
||||
SECTION = "Wayland"
|
||||
LICENSE = "MIT"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=e316e9609dd7672b87ff25b46b2cf3e1"
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
SRC_URI = " \
|
||||
git://github.com/emersion/mako.git;protocol=https \
|
||||
file://0001-meson.build-fix-scdoc-not-to-be-found.patch \
|
||||
"
|
||||
|
||||
DEPENDS = " \
|
||||
pango \
|
||||
cairo \
|
||||
libpng \
|
||||
wayland \
|
||||
wayland-native \
|
||||
wayland-protocols \
|
||||
"
|
||||
|
||||
RDEPENDS_${PN} = "dbus"
|
||||
|
||||
RRECOMMENDS_${PN} = "jq"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
||||
PACKAGECONFIG[systemd] = ",,systemd"
|
||||
PACKAGECONFIG[sysvinit] = ",,elogind"
|
||||
PACKAGECONFIG[man-pages] = ",,scdoc-native"
|
||||
PACKAGECONFIG[icons] = ",,gdk-pixbuf"
|
||||
|
||||
PACKAGECONFIG ?= " \
|
||||
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
|
||||
${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)} \
|
||||
icons \
|
||||
man-pages \
|
||||
"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
PV = "1.6"
|
||||
SRCREV = "v${PV}"
|
||||
|
||||
EXTRA_OEMESON += "--buildtype release"
|
||||
|
||||
FILES_${PN} += "${datadir}"
|
||||
|
||||
BBCLASSEXTEND = ""
|
||||
|
Loading…
Reference in New Issue
Block a user