wlroots: remove unneeded patches

This commit is contained in:
Markus Volk 2023-01-31 12:13:16 +01:00
parent c5b93f3e46
commit 4d9e9fd192
4 changed files with 4 additions and 63 deletions

View File

@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7578fad101710ea2d289ff5411f1b818"
REQUIRED_DISTRO_FEATURES = "wayland"
DEPENDS += " \
hwdata \
hwdata-native \
libdrm \
libxkbcommon \
pixman \
@ -37,10 +37,7 @@ PACKAGECONFIG ?= " \
libinput \
"
SRC_URI = " \
git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=master;protocol=https \
file://0001-backend-drm-meson.build-dont-use-native-hwdata.patch \
"
SRC_URI = "git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=master;protocol=https"
SRCREV = "1712a7d27444d62f8da8eeedf0840b386a810e96"
S = "${WORKDIR}/git"

View File

@ -1,26 +0,0 @@
From 1a7c0aeadd27eaa5454d40fd6415ab4d0afecb94 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Fri, 11 Nov 2022 03:25:19 +0100
Subject: [PATCH] backend/drm/meson.build: dont use native hwdata
hwdata is allarch, there's no need to build a native package.
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Upstream-Status: inappropriate (oe specific) [https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/3844]
---
backend/drm/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/backend/drm/meson.build b/backend/drm/meson.build
index 7bde50c25..8aa404c4b 100644
--- a/backend/drm/meson.build
+++ b/backend/drm/meson.build
@@ -1,4 +1,4 @@
-hwdata = dependency('hwdata', required: false, native: true)
+hwdata = dependency('hwdata', required: false)
if hwdata.found()
hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
pnp_ids = files(hwdata_dir / 'pnp.ids')
--
2.34.1

View File

@ -1,27 +0,0 @@
From 55c9c3ac4c1eb645476a725fbab1d9046cbacb16 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Tue, 6 Dec 2022 16:18:41 +0100
Subject: [PATCH] meson.build: dont use native hwdata
Upstream-Status: inappropriate (oe specific) [https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/3844]
---
backend/drm/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/backend/drm/meson.build b/backend/drm/meson.build
index fc4d84d6f..b01818901 100644
--- a/backend/drm/meson.build
+++ b/backend/drm/meson.build
@@ -2,7 +2,7 @@ if not features['session']
subdir_done()
endif
-hwdata = dependency('hwdata', required: false, native: true)
+hwdata = dependency('hwdata', required: false)
if hwdata.found()
hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
pnp_ids = files(hwdata_dir / 'pnp.ids')
--
2.34.1

View File

@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7578fad101710ea2d289ff5411f1b818"
REQUIRED_DISTRO_FEATURES = "wayland"
DEPENDS += " \
hwdata \
hwdata-native \
libdrm \
libxkbcommon \
pixman \
@ -37,10 +37,7 @@ PACKAGECONFIG ?= " \
libinput \
"
SRC_URI = " \
git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=master;protocol=https \
file://0001-backend-drm-meson.build-dont-use-native-hwdata.patch \
"
SRC_URI = "git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=master;protocol=https"
SRCREV = "869af1cfbb3944d32d59a4c08ca439e7b5eaf6d2"
PV = "0.17.0-dev"