mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-20 04:18:25 +01:00
wayfire: update
This commit is contained in:
parent
3f838eeb35
commit
3a811ee4bb
@ -1,35 +0,0 @@
|
||||
From b8ba62e91d30ede97478f66587300525c5d7bd7e Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Tue, 15 Feb 2022 01:40:30 +0100
|
||||
Subject: [PATCH] meson.build: build with system wf-touch and wf-utils
|
||||
|
||||
---
|
||||
meson.build | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index ab3652a8..a9f287e2 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -32,6 +32,8 @@ threads = dependency('threads')
|
||||
xkbcommon = dependency('xkbcommon')
|
||||
wlroots = dependency('wlroots', version: ['>=0.15.0', '<0.16.0'], required: get_option('use_system_wlroots'))
|
||||
wfconfig = dependency('wf-config', version: ['>=0.7.0', '<0.8.0'], required: get_option('use_system_wfconfig'))
|
||||
+wfutils = dependency('wf-utils', version: '>=0.4.0')
|
||||
+wftouch = dependency('wf-touch')
|
||||
|
||||
use_system_wlroots = not get_option('use_system_wlroots').disabled() and wlroots.found()
|
||||
if not use_system_wlroots
|
||||
@@ -43,9 +45,6 @@ if not use_system_wfconfig
|
||||
wfconfig = subproject('wf-config').get_variable('wfconfig')
|
||||
endif
|
||||
|
||||
-wfutils = subproject('wf-utils').get_variable('wfutils')
|
||||
-wftouch = subproject('wf-touch').get_variable('wftouch')
|
||||
-
|
||||
needs_libinotify = ['freebsd', 'dragonfly'].contains(host_machine.system())
|
||||
libinotify = dependency('libinotify', required: needs_libinotify)
|
||||
|
||||
--
|
||||
2.25.1
|
||||
|
@ -10,34 +10,27 @@ REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
DEPENDS += " \
|
||||
cairo \
|
||||
ffmpeg \
|
||||
freetype \
|
||||
glm \
|
||||
jpeg \
|
||||
libdrm \
|
||||
libevdev \
|
||||
libnotify \
|
||||
libinput \
|
||||
libpng \
|
||||
libxkbcommon \
|
||||
libxml2 \
|
||||
mesa \
|
||||
nlohmann-json \
|
||||
pango \
|
||||
pixman \
|
||||
seatd \
|
||||
wayland \
|
||||
wayland-native \
|
||||
wayland-protocols \
|
||||
wf-config \
|
||||
wf-utils \
|
||||
wf-touch \
|
||||
"
|
||||
|
||||
RRECOMMENDS:${PN} += " \
|
||||
wcm \
|
||||
wf-config \
|
||||
wf-touch \
|
||||
wf-utils \
|
||||
wf-recorder \
|
||||
wf-shell \
|
||||
"
|
||||
@ -45,20 +38,19 @@ RRECOMMENDS:${PN} += " \
|
||||
PACKAGECONFIG[gles32] = "-Denable_gles32=true,-Denable_gles32=false"
|
||||
PACKAGECONFIG[use_system_wfconfig] = "-Duse_system_wfconfig=enabled,-Duse_system_wfconfig=disabled,wf-config"
|
||||
PACKAGECONFIG[use_system_wlroots] = "-Duse_system_wlroots=enabled,-Duse_system_wlroots=disabled,wlroots"
|
||||
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled"
|
||||
PACKAGECONFIG[x11] = "-Dxwayland=enabled,-Dxwayland=disabled,xwayland xcb-util-renderutil xcb-util-wm"
|
||||
PACKAGECONFIG[vulkan] = ",,vulkan-loader vulkan-headers glslang-native"
|
||||
|
||||
PACKAGECONFIG ?= " \
|
||||
${@bb.utils.filter('DISTRO_FEATURES', 'vulkan x11', d)} \
|
||||
gles32 \
|
||||
use_system_wfconfig \
|
||||
"
|
||||
|
||||
SRC_URI = " \
|
||||
gitsm://github.com/WayfireWM/wayfire.git;protocol=https;branch=0.7.x \
|
||||
file://0001-meson.build-build-with-system-wf-touch-and-wf-utils.patch \
|
||||
"
|
||||
SRC_URI = "gitsm://github.com/WayfireWM/wayfire.git;protocol=https;branch=master"
|
||||
|
||||
SRCREV = "0f0b1642183007b0e58ad4d4e5f9e86d16355ea7"
|
||||
PV = "0.7.4"
|
||||
SRCREV = "9450147d118e0636e4c6dfc1b066ef1c4b91acdd"
|
||||
PV = "0.8.0"
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
@ -11,15 +11,15 @@ DEPENDS = " \
|
||||
wayland-native \
|
||||
wayland-protocols \
|
||||
gtkmm3 \
|
||||
wf-config \
|
||||
wf-shell \
|
||||
"
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
SRC_URI = "https://github.com/WayfireWM/wcm/releases/download/v${PV}/wcm-${PV}.tar.xz"
|
||||
SRC_URI[sha256sum] = "924a9682dc2f632bad8b6914a8927ad5dcee4b6698f75e89251f1647ad0beaa7"
|
||||
|
||||
S = "${WORKDIR}/${PN}-${PV}"
|
||||
SRC_URI = "gitsm://github.com/WayfireWM/wcm.git;protocol=https;branch=master"
|
||||
SRCREV = "4c80340e7a207adb203037094ab378d933839485"
|
||||
S = "${WORKDIR}/git"
|
||||
PV = "0.8.0"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
@ -14,9 +14,9 @@ DEPENDS = " \
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
SRC_URI = "git://github.com/WayfireWM/wf-config.git;protocol=https;branch=0.7.x"
|
||||
SRCREV = "62e3897f207f49b1a3bbb85ba4b11d9fea239ec1"
|
||||
PV = "0.7.1"
|
||||
SRC_URI = "git://github.com/WayfireWM/wf-config.git;protocol=https;branch=master"
|
||||
SRCREV = "e42a3870fb194842a505ad5a9671be1aebda0b0b"
|
||||
PV = "0.8.0"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
|
@ -20,13 +20,10 @@ DEPENDS = " \
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
SRC_URI = " \
|
||||
https://github.com/WayfireWM/wf-shell/releases/download/v${PV}/wf-shell-${PV}.tar.xz \
|
||||
"
|
||||
|
||||
SRC_URI[sha256sum] = "7495c690a1c021e0c82ba304513b3e7870cb329f7f0bf88df3bc5f46535d5ec7"
|
||||
|
||||
S = "${WORKDIR}/${PN}-${PV}"
|
||||
SRC_URI = "gitsm://github.com/WayfireWM/wf-shell.git;protocol=https;branch=master"
|
||||
SRCREV = "bad121a4d7b8a7bca8513e8cb62e6be951aacfc4"
|
||||
S = "${WORKDIR}/git"
|
||||
PV = "0.8.0"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 78024c2654dab996d43f27aa3f3276360c357baa Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Tue, 15 Feb 2022 01:29:13 +0100
|
||||
Subject: [PATCH] meson.build: create .pc file
|
||||
|
||||
---
|
||||
meson.build | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 33dbb59..bd4172d 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -21,3 +21,11 @@ doctest = dependency('doctest', required: get_option('tests'))
|
||||
if doctest.found()
|
||||
subdir('test')
|
||||
endif
|
||||
+
|
||||
+pkgconfig = import('pkgconfig')
|
||||
+pkgconfig.generate(
|
||||
+ libraries: wftouch_lib,
|
||||
+ version: meson.project_version(),
|
||||
+ filebase: meson.project_name(),
|
||||
+ name: meson.project_name(),
|
||||
+ description: 'Touch library for Wayfire')
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,27 +0,0 @@
|
||||
SUMMARY = "Touchscreen gesture library"
|
||||
HOMEPAGE = "https://github.com/WayfireWM/wf-touch"
|
||||
BUGTRACKER = "https://github.com/WayfireWM/wf-touch/issues"
|
||||
SECTION = "graphics"
|
||||
LICENSE = "MIT"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=a5edde5b0aa2298140a914608a192560"
|
||||
|
||||
DEPENDS = "glm"
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
SRC_URI = " \
|
||||
git://github.com/WayfireWM/wf-touch.git;branch=master;protocol=https \
|
||||
file://0001-meson.build-create-.pc-file.patch \
|
||||
"
|
||||
|
||||
SRCREV = "8974eb0f6a65464b63dd03b842795cb441fb6403"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
||||
EXTRA_OEMESON += "--buildtype release"
|
||||
|
||||
BBCLASSEXTEND = ""
|
||||
|
@ -1,24 +0,0 @@
|
||||
From 3fcdc43e301b5f166619689caac4751b601faf08 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Tue, 15 Feb 2022 01:03:03 +0100
|
||||
Subject: [PATCH] meson.build: add missing header
|
||||
|
||||
---
|
||||
meson.build | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 43b60e8..94c9f84 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -76,6 +76,7 @@ headers_parser = [
|
||||
'wayfire/parser/action_parser.hpp',
|
||||
'wayfire/parser/condition_parser.hpp',
|
||||
'wayfire/parser/rule_parser.hpp',
|
||||
+'wayfire/parser/lambda_rule_parser.hpp',
|
||||
]
|
||||
|
||||
headers_rule = [
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,25 +0,0 @@
|
||||
SUMMARY = "Contains utility classes for Wayfire"
|
||||
HOMEPAGE = "https://github.com/WayfireWM/wf-utils"
|
||||
BUGTRACKER = "https://github.com/WayfireWM/wf-utils/issues"
|
||||
SECTION = "graphics"
|
||||
LICENSE = "MIT"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=a5edde5b0aa2298140a914608a192560"
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "wayland"
|
||||
|
||||
SRC_URI = " \
|
||||
git://github.com/WayfireWM/wf-utils.git;branch=master;protocol=https \
|
||||
file://0001-meson.build-add-missing-header.patch \
|
||||
"
|
||||
|
||||
SRCREV = "889fdafa7b09fc6ce70313fd3f067cfc8c21a2ac"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
inherit meson pkgconfig features_check
|
||||
|
||||
EXTRA_OEMESON += "--buildtype release"
|
||||
|
||||
BBCLASSEXTEND = ""
|
||||
|
Loading…
Reference in New Issue
Block a user