gtk4-layer-shell: add recipe

This commit is contained in:
Markus Volk 2023-04-16 21:36:06 +02:00
parent e1747dae13
commit 31cf2edc93
2 changed files with 57 additions and 0 deletions

View File

@ -0,0 +1,23 @@
From 25e9ac8ce8aba85f0c4e3c643d517fecc6e2fd96 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Sat, 9 Jul 2022 01:08:21 +0200
Subject: [PATCH] protocol/meson.build: dont use pkgconfig for wayland-scanner
wayland-scanner path gets read from target waylands .pc file. Avoid it
---
protocol/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/protocol/meson.build b/protocol/meson.build
index 2ce0e0c..12f389f 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -1,4 +1,4 @@
-if wayland_scanner.found()
+if false
prog_wayland_scanner = find_program(wayland_scanner.get_pkgconfig_variable('wayland_scanner'))
else
prog_wayland_scanner = find_program('wayland-scanner')
--
2.25.1

View File

@ -0,0 +1,34 @@
SUMMARY = "A library to write GTK applications that use Layer Shell"
HOMEPAGE = "https://github.com/wmww/gtk-layer-shell"
BUGTRACKER = "https://github.com/www/gtk-layer-shell/issues"
SECTION = "graphics"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c10fc088fd05226381f6a90310ef75b5"
REQUIRED_DISTRO_FEATURES = "wayland gobject-introspection-data"
DEPENDS += " \
gtk4 \
wayland \
wayland-native \
wayland-protocols \
"
SRC_URI = " \
git://github.com/wmww/gtk4-layer-shell.git;protocol=https;branch=main \
file://0001-protocol-meson.build-dont-use-pkgconfig-for-wayland-.patch \
"
S = "${WORKDIR}/git"
PV = "1.0.0"
SRCREV = "a9c679e23fe27dd35bd4084938d407d0baf5c91c"
inherit meson pkgconfig features_check gobject-introspection vala
EXTRA_OEMESON += "--buildtype release"
FILES:${PN} = "${datadir} ${libdir}"
BBCLASSEXTEND = ""