sway-1.8: import patch for updated libinput

- fix PN
This commit is contained in:
Markus Volk 2023-05-17 16:52:57 +02:00
parent f56dc42014
commit 3116be4cba
2 changed files with 55 additions and 3 deletions

View File

@ -36,11 +36,14 @@ RRECOMMENDS:${PN} ?= " \
wl-clipboard \
"
SRC_URI = "git://github.com/swaywm/sway.git;protocol=https;branch=v1.8"
SRC_URI = " \
git://github.com/swaywm/sway.git;protocol=https;branch=v1.8 \
file://sway-999.01-fix-build-with-updated-libinput.patch \
"
SRCREV = "b88b1b6302cf68cc50ee7f3279b2f2ff29e292c8"
SRCREV = "68d620a8fd70d70eb91c58dcfafc4af16c58379d"
S = "${WORKDIR}/git"
PV = "0.8"
PV = "0.8.1"
inherit meson pkgconfig features_check

View File

@ -0,0 +1,49 @@
From dee032d0a0ecd958c902b88302dc59703d703c7f Mon Sep 17 00:00:00 2001
From: Simon Ser <contact@emersion.fr>
Date: Sun, 26 Mar 2023 23:27:40 +0200
Subject: [PATCH] ipc: add LIBINPUT_CONFIG_ACCEL_PROFILE_CUSTOM entry
This was introduced in the last libinput release.
Fixes the following error:
../sway/ipc-json.c:928:17: error: enumeration value 'LIBINPUT_CONFIG_ACCEL_PROFILE_CUSTOM' not handled in switch [-Werror=switch]
928 | switch (libinput_device_config_accel_get_profile(device)) {
| ^~~~~~
---
meson.build | 5 +++++
sway/ipc-json.c | 5 +++++
2 files changed, 10 insertions(+)
diff --git a/meson.build b/meson.build
index 84e7c6c56f..d1fbfa38ab 100644
--- a/meson.build
+++ b/meson.build
@@ -117,6 +117,11 @@ conf_data.set10('HAVE_LIBSYSTEMD', sdbus.found() and sdbus.name() == 'libsystemd
conf_data.set10('HAVE_LIBELOGIND', sdbus.found() and sdbus.name() == 'libelogind')
conf_data.set10('HAVE_BASU', sdbus.found() and sdbus.name() == 'basu')
conf_data.set10('HAVE_TRAY', have_tray)
+conf_data.set10('HAVE_LIBINPUT_CONFIG_ACCEL_PROFILE_CUSTOM', cc.has_header_symbol(
+ 'libinput.h',
+ 'LIBINPUT_CONFIG_ACCEL_PROFILE_CUSTOM',
+ dependencies: libinput,
+))
scdoc = dependency('scdoc', version: '>=1.9.2', native: true, required: get_option('man-pages'))
if scdoc.found()
diff --git a/sway/ipc-json.c b/sway/ipc-json.c
index 51e6a99518..c7cbea0136 100644
--- a/sway/ipc-json.c
+++ b/sway/ipc-json.c
@@ -935,6 +935,11 @@ static json_object *describe_libinput_device(struct libinput_device *device) {
case LIBINPUT_CONFIG_ACCEL_PROFILE_ADAPTIVE:
accel_profile = "adaptive";
break;
+#if HAVE_LIBINPUT_CONFIG_ACCEL_PROFILE_CUSTOM
+ case LIBINPUT_CONFIG_ACCEL_PROFILE_CUSTOM:
+ accel_profile = "custom";
+ break;
+#endif
}
json_object_object_add(object, "accel_profile",
json_object_new_string(accel_profile));