mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-11-19 20:08:27 +01:00
uwsm: add recipe
This commit is contained in:
parent
742258e97c
commit
28a146b340
@ -0,0 +1,38 @@
|
||||
From 3f89fbb25bee0064d74f882ea9fc73ad39234d34 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Thu, 14 Nov 2024 22:15:49 +0100
|
||||
Subject: [PATCH] uwsm/meson.build: dont fail for missing python-modules
|
||||
|
||||
Otherwise python-dbus-native and pyxdg-native would be required for build
|
||||
but are only runtime dpendencies
|
||||
---
|
||||
uwsm/meson.build | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/uwsm/meson.build b/uwsm/meson.build
|
||||
index d2ecf6b..c5ab845 100644
|
||||
--- a/uwsm/meson.build
|
||||
+++ b/uwsm/meson.build
|
||||
@@ -14,13 +14,13 @@ has_system_xdg = \
|
||||
check: false,
|
||||
).returncode() == 0
|
||||
|
||||
-if not has_system_dbus
|
||||
- error('python dbus module not found')
|
||||
-endif
|
||||
+#if not has_system_dbus
|
||||
+# error('python dbus module not found')
|
||||
+#endif
|
||||
|
||||
-if not has_system_xdg
|
||||
- error('python xdg module not found')
|
||||
-endif
|
||||
+#if not has_system_xdg
|
||||
+# error('python xdg module not found')
|
||||
+#endif
|
||||
|
||||
conf = configuration_data()
|
||||
conf.set('PROJECT_NAME', PROJECT_NAME)
|
||||
--
|
||||
2.47.0
|
||||
|
26
recipes-extended/uwsm/uwsm_git.bb
Normal file
26
recipes-extended/uwsm/uwsm_git.bb
Normal file
@ -0,0 +1,26 @@
|
||||
SUMMARY = "Wraps standalone Wayland compositors into a set of Systemd units on the fly"
|
||||
HOMEPAGE = "https://github.com/Vladimir-csp/uwsm"
|
||||
LICENSE = "MIT"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=0bcdc63de832340797303f320ae6af32"
|
||||
|
||||
inherit meson pkgconfig
|
||||
|
||||
EXTRA_OEMESON = "-Dpython-bin=${bindir}/python3"
|
||||
|
||||
SRC_URI = " \
|
||||
git://github.com/Vladimir-csp/uwsm.git;protocol=https;branch=master \
|
||||
file://0001-uwsm-meson.build-dont-fail-for-missing-python-module.patch \
|
||||
"
|
||||
SRCREV = "46f81e90d1f2554ae1ce98370817cce7be164981"
|
||||
PV = "0.20.4"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
PACKAGECONFIG ?= "man-pages uuctl"
|
||||
PACKAGECONFIG[man-pages] = "-Dman-pages=enabled,-Dman-pages=disabled,scdoc-native"
|
||||
PACKAGECONFIG[uuctl] = "-Duuctl=enabled,-Duuctl=disabled,,libnewt"
|
||||
|
||||
FILES:${PN} += "${datadir}/licenses"
|
||||
|
||||
RDEPENDS:${PN} = "python3-dbus pyxdg python3-core"
|
||||
RRECOMMENDS:${PN} = "dbus-broker"
|
Loading…
Reference in New Issue
Block a user