mirror of
https://codeberg.org/flk/meta-wayland.git
synced 2024-12-26 13:38:22 +01:00
gamescope: update
This commit is contained in:
parent
88defa0ae1
commit
27d655d000
@ -10,13 +10,13 @@ manually add it to CXXFLAGS
|
|||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/meson.build b/src/meson.build
|
diff --git a/src/meson.build b/src/meson.build
|
||||||
index 7f7e793..c61077f 100644
|
index e0254e6..e6e88bd 100644
|
||||||
--- a/src/meson.build
|
--- a/src/meson.build
|
||||||
+++ b/src/meson.build
|
+++ b/src/meson.build
|
||||||
@@ -20,7 +20,7 @@ cap_dep = dependency('libcap', required: get_option('rt_cap'))
|
@@ -21,7 +21,7 @@ cap_dep = dependency('libcap', required: get_option('rt_cap'))
|
||||||
epoll_dep = dependency('epoll-shim', required: false)
|
epoll_dep = dependency('epoll-shim', required: false)
|
||||||
glm_dep = dependency('glm')
|
glm_dep = dependency('glm')
|
||||||
sdl_dep = dependency('SDL2', required: get_option('sdl2_backend'))
|
sdl2_dep = dependency('SDL2', required: get_option('sdl2_backend'))
|
||||||
-stb_dep = dependency('stb')
|
-stb_dep = dependency('stb')
|
||||||
+stb_dep = dependency('stb', required: false)
|
+stb_dep = dependency('stb', required: false)
|
||||||
avif_dep = dependency('libavif', version: '>=1.0.0', required: get_option('avif_screenshots'))
|
avif_dep = dependency('libavif', version: '>=1.0.0', required: get_option('avif_screenshots'))
|
||||||
|
@ -13,6 +13,7 @@ DEPENDS += " \
|
|||||||
libei \
|
libei \
|
||||||
libdecor \
|
libdecor \
|
||||||
libdisplay-info \
|
libdisplay-info \
|
||||||
|
libdrm \
|
||||||
libinput \
|
libinput \
|
||||||
libx11\
|
libx11\
|
||||||
libxcomposite \
|
libxcomposite \
|
||||||
@ -22,6 +23,10 @@ DEPENDS += " \
|
|||||||
libxmu \
|
libxmu \
|
||||||
libxrender \
|
libxrender \
|
||||||
libxtst \
|
libxtst \
|
||||||
|
libxxf86vm \
|
||||||
|
libxfixes \
|
||||||
|
libxext \
|
||||||
|
libxdamage \
|
||||||
seatd \
|
seatd \
|
||||||
stb \
|
stb \
|
||||||
vulkan-loader \
|
vulkan-loader \
|
||||||
@ -37,7 +42,7 @@ RDEPENDS:${PN} = "xwayland hwdata"
|
|||||||
|
|
||||||
CXXFLAGS:append = " -I${STAGING_INCDIR}/stb"
|
CXXFLAGS:append = " -I${STAGING_INCDIR}/stb"
|
||||||
|
|
||||||
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pipewire', d)} rt_cap avif_screenshots openvr input_emulation drm_backend sdl2_backend"
|
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pipewire', d)} rt_cap avif_screenshots openvr input_emulation drm_backend"
|
||||||
PACKAGECONFIG[benchmark] = "-Dbenchmark=enabled,-Dbenchmark=disabled"
|
PACKAGECONFIG[benchmark] = "-Dbenchmark=enabled,-Dbenchmark=disabled"
|
||||||
PACKAGECONFIG[input_emulation] = "-Dinput_emulation=enabled,-Dinput_emulation=disabled,libei"
|
PACKAGECONFIG[input_emulation] = "-Dinput_emulation=enabled,-Dinput_emulation=disabled,libei"
|
||||||
PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=false"
|
PACKAGECONFIG[openvr] = "-Denable_openvr_support=true,-Denable_openvr_support=false"
|
||||||
@ -45,15 +50,15 @@ PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
|
|||||||
PACKAGECONFIG[avif_screenshots] = "-Davif_screenshots=enabled,-Davif_screenshots=disabled,libavif"
|
PACKAGECONFIG[avif_screenshots] = "-Davif_screenshots=enabled,-Davif_screenshots=disabled,libavif"
|
||||||
PACKAGECONFIG[rt_cap] = "-Drt_cap=enabled,-Drt_cap=disabled,libcap"
|
PACKAGECONFIG[rt_cap] = "-Drt_cap=enabled,-Drt_cap=disabled,libcap"
|
||||||
PACKAGECONFIG[sdl2_backend] = "-Dsdl2_backend=enabled,-Dsdl2_backend=disabled,libsdl2"
|
PACKAGECONFIG[sdl2_backend] = "-Dsdl2_backend=enabled,-Dsdl2_backend=disabled,libsdl2"
|
||||||
PACKAGECONFIG[drm_backend] = "-Ddrm_backend=enabled,-Ddrm_backend=disabled,libdrm"
|
PACKAGECONFIG[drm_backend] = "-Ddrm_backend=enabled,-Ddrm_backend=disabled"
|
||||||
|
|
||||||
SRC_URI = " \
|
SRC_URI = " \
|
||||||
gitsm://github.com/ValveSoftware/gamescope.git;branch=jupiter-3.6;protocol=https \
|
gitsm://github.com/ValveSoftware/gamescope.git;branch=master;protocol=https \
|
||||||
file://0001-meson.build-dont-fail-if-stb-is-not-found.patch \
|
file://0001-meson.build-dont-fail-if-stb-is-not-found.patch \
|
||||||
file://0001-meson.build-dont-leak-buildpath.patch \
|
file://0001-meson.build-dont-leak-buildpath.patch \
|
||||||
"
|
"
|
||||||
SRCREV = "420eb91387a484fd7b1ea71449091f0480d9e538"
|
SRCREV = "3b69847e15c84c0a4f93e82c2eb16b623f9765b9"
|
||||||
PV = "3.14.18"
|
PV = "3.14.22"
|
||||||
|
|
||||||
S = "${WORKDIR}/git"
|
S = "${WORKDIR}/git"
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user