phoc: update; dont build subprojects

This commit is contained in:
Markus Volk 2023-08-15 08:46:46 +02:00
parent a5ad9dd237
commit 109dfd7de5
2 changed files with 53 additions and 14 deletions

View File

@ -0,0 +1,44 @@
From 92e876d5f678228971512045144b0e8b572b9953 Mon Sep 17 00:00:00 2001
From: Markus Volk <f_l_k@t-online.de>
Date: Tue, 15 Aug 2023 07:23:23 +0200
Subject: [PATCH] meson.build: dont build subprojects
Upstream-Status: Inappropriate
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
meson.build | 9 ++-------
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/meson.build b/meson.build
index 77b8971..e5b0908 100644
--- a/meson.build
+++ b/meson.build
@@ -40,13 +40,7 @@ wayland_protos = dependency('wayland-protocols', version: '>=1.15')
wayland_server = dependency('wayland-server')
xkbcommon = dependency('xkbcommon')
math = cc.find_library('m')
-gmobile = subproject('gmobile',
- default_options: [
- 'examples=false',
- 'gtk_doc=false',
- 'tests=false',
- ])
-gmobile_dep = gmobile.get_variable('gmobile_dep')
+gmobile_dep = dependency('gmobile', version: '>= 0.0.3')
embed_wlroots = get_option('embed-wlroots')
@@ -66,7 +60,7 @@ endif
if not embed_wlroots.disabled() and wlroots_proj.found()
wlroots = wlroots_proj.get_variable('wlroots')
else
- wlroots = dependency('wlroots', version: '>= 0.16.0')
+ wlroots = dependency('wlroots', version: '>= 0.16.2')
endif
wlroots_has_xwayland = wlroots.get_variable(pkgconfig: 'have_xwayland',
internal: 'have_xwayland') == 'true'
--
2.41.0

View File

@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
REQUIRED_DISTRO_FEATURES = "wayland"
DEPENDS += " \
gi-docgen-native \
glib-2.0 \
gmobile \
gnome-desktop \
@ -19,25 +20,19 @@ DEPENDS += " \
wayland \
wayland-native \
wayland-protocols \
"
#needed to build wlroots as a subproject
DEPENDS += " \
ffmpeg \
git-native \
libdrm \
libcap \
virtual/libgbm \
virtual/libgles2 \
libpng \
wlroots-0.16 \
"
RDEPENDS:${PN} = "mutter"
SRC_URI = "gitsm://gitlab.gnome.org/World/Phosh/phoc.git;protocol=https;nobranch=1"
SRC_URI = " \
git://gitlab.gnome.org/World/Phosh/phoc.git;protocol=https;nobranch=1 \
file://0001-meson.build-dont-build-subprojects.patch \
"
S = "${WORKDIR}/git"
PV = "0.28.0"
SRCREV = "ec5e24da547e60ee76df8166e27ea77db5865da5"
PV = "0.30.0"
SRCREV = "0b14b8837a37977b3252ce957802469491f58ee2"
inherit features_check gsettings meson pkgconfig
@ -51,7 +46,7 @@ PACKAGECONFIG ?= " \
${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)} \
"
EXTRA_OEMESON += "-Dembed-wlroots=enabled --buildtype=release"
EXTRA_OEMESON += "-Dembed-wlroots=disabled --buildtype=release"
FILES:${PN} += "${datadir}"