meta-sunxi/recipes-kernel/linux/linux/0001-aufs3-kbuild.patch
2012-10-17 19:21:01 +02:00

38 lines
1017 B
Diff

aufs3.0 kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index 19891aa..b660b64 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -208,5 +208,6 @@ source "fs/pstore/Kconfig"
source "fs/sysv/Kconfig"
source "fs/ufs/Kconfig"
source "fs/exofs/Kconfig"
+source "fs/aufs/Kconfig"
endif # MISC_FILESYSTEMS
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
index 01f6362..8b3b9f1 100644
--- a/include/linux/Kbuild
+++ b/include/linux/Kbuild
@@ -65,6 +65,7 @@ header-y += atmppp.h
header-y += atmsap.h
header-y += atmsvc.h
header-y += audit.h
+header-y += aufs_type.h
header-y += auto_fs.h
header-y += auto_fs4.h
header-y += auxvec.h
diff --git a/fs/Makefile b/fs/Makefile
index 2999b4d..60af3ce 100644
--- a/fs/Makefile
+++ b/fs/Makefile
@@ -124,6 +124,7 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
obj-$(CONFIG_EXOFS_FS) += exofs/
obj-$(CONFIG_CEPH_FS) += ceph/
obj-$(CONFIG_PSTORE) += pstore/
+obj-$(CONFIG_AUFS_FS) += aufs/
# Patched by YAFFS
obj-$(CONFIG_YAFFS_FS) += yaffs2/