u-boot: upgrade to 2018.09

Bump u-boot version. Notes:
- pylibfdt fix is not needed anymore
- add bison and flex as depenedencies
- update license info

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
This commit is contained in:
Sergey Matyukevich 2018-11-10 21:58:32 +03:00
parent 712229cbe4
commit 6b536f1083
13 changed files with 19 additions and 42 deletions

View File

@ -5,7 +5,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "sun8i-h3-nanopi-neo-air.dtb"
UBOOT_MACHINE = "nanopi_neo_air_defconfig"

View File

@ -5,7 +5,7 @@
require conf/machine/include/sun50i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "allwinner/sun50i-h5-nanopi-neo-plus2.dtb"
UBOOT_MACHINE = "nanopi_neo_plus2_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "sun8i-h3-nanopi-neo.dtb"
UBOOT_MACHINE = "nanopi_neo_defconfig"

View File

@ -5,7 +5,7 @@
require conf/machine/include/sun50i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "allwinner/sun50i-h5-nanopi-neo2.dtb"
UBOOT_MACHINE = "nanopi_neo2_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "sun8i-h3-orangepi-one.dtb"
UBOOT_MACHINE = "orangepi_one_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "sun8i-h3-orangepi-pc-plus.dtb"
UBOOT_MACHINE = "orangepi_pc_plus_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "sun8i-h3-orangepi-pc.dtb"
UBOOT_MACHINE = "orangepi_pc_defconfig"

View File

@ -5,7 +5,7 @@
require conf/machine/include/sun50i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "allwinner/sun50i-h5-orangepi-zero-plus2.dtb"
UBOOT_MACHINE = "orangepi_zero_plus2_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun8i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "sun8i-h2-plus-orangepi-zero.dtb"
UBOOT_MACHINE = "orangepi_zero_defconfig"

View File

@ -4,7 +4,7 @@
require conf/machine/include/sun4i.inc
PREFERRED_VERSION_u-boot = "v2018.03%"
PREFERRED_VERSION_u-boot = "v2018.09%"
KERNEL_DEVICETREE = "sun4i-a10-pcduino.dtb"
UBOOT_MACHINE = "Linksprite_pcDuino_defconfig"

View File

@ -10,17 +10,11 @@ Signed-off-by: Florin Sarbu <florin@resin.io>
1 file changed, 1 insertion(+)
diff --git a/configs/nanopi_neo_air_defconfig b/configs/nanopi_neo_air_defconfig
index ca9c2dd..74ce044 100644
index 8c362fa885..c7929ff015 100644
--- a/configs/nanopi_neo_air_defconfig
+++ b/configs/nanopi_neo_air_defconfig
@@ -10,6 +10,7 @@ CONFIG_DEFAULT_DEVICE_TREE="sun8i-h3-nanopi-neo-air"
# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
CONFIG_CONSOLE_MUX=y
CONFIG_SPL=y
@@ -15,3 +15,4 @@ CONFIG_CONSOLE_MUX=y
CONFIG_DEFAULT_DEVICE_TREE="sun8i-h3-nanopi-neo-air"
CONFIG_USB_EHCI_HCD=y
CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y
+CONFIG_MMC_SUNXI_SLOT_EXTRA=2
# CONFIG_CMD_FLASH is not set
# CONFIG_SPL_DOS_PARTITION is not set
# CONFIG_SPL_ISO_PARTITION is not set
--
2.7.4

View File

@ -1,16 +0,0 @@
diff --git a/scripts/dtc/pylibfdt/Makefile b/scripts/dtc/pylibfdt/Makefile
index 01d5e0ffe3..2b2dfe0bd9 100644
--- a/scripts/dtc/pylibfdt/Makefile
+++ b/scripts/dtc/pylibfdt/Makefile
@@ -15,6 +15,8 @@ PYLIBFDT_srcs = $(addprefix $(LIBFDT_srcdir)/,$(LIBFDT_SRCS)) \
quiet_cmd_pymod = PYMOD $@
cmd_pymod = unset CC; unset CROSS_COMPILE; unset CFLAGS;\
+ CC="$(HOSTCC)" \
+ LDSHARED="$(HOSTLDSHARED)" \
LDFLAGS="$(HOSTLDFLAGS)" \
VERSION="u-boot-$(UBOOTVERSION)" \
CPPFLAGS="$(HOSTCFLAGS) -I$(LIBFDT_srcdir)" OBJDIR=$(obj) \
--
2.11.0

View File

@ -2,11 +2,11 @@ DESCRIPTION="Upstream's U-boot configured for sunxi devices"
require recipes-bsp/u-boot/u-boot.inc
DEPENDS += " bc-native dtc-native swig-native python3-native "
DEPENDS += " bc-native dtc-native swig-native python3-native flex-native bison-native "
DEPENDS_append_sun50i = " atf-sunxi "
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
COMPATIBLE_MACHINE = "(sun4i|sun5i|sun7i|sun8i|sun50i)"
@ -17,14 +17,13 @@ DEFAULT_PREFERENCE_sun8i="1"
DEFAULT_PREFERENCE_sun50i="1"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master \
file://u-boot-pylibfdt-native-build.patch \
file://0001-nanopi_neo_air_defconfig-Enable-eMMC-support.patch \
file://boot.cmd \
"
SRCREV = "f95ab1fb6e37f0601f397091bb011edf7a98b890"
SRCREV = "f88b6facb87dc4a52f1630eb9d858c0f54c6628e"
PV = "v2018.03+git${SRCPV}"
PV = "v2018.09+git${SRCPV}"
PE = "2"
S = "${WORKDIR}/git"