mirror of
https://github.com/linux-sunxi/meta-sunxi.git
synced 2024-11-16 10:18:23 +01:00
xradio: Drop unnecessary patch when fix module compilation
Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
This commit is contained in:
parent
76a5f2b367
commit
6408de735c
@ -14,9 +14,10 @@ COMPATIBLE_MACHINE = "orange-pi-zero"
|
|||||||
SRCREV = "d649e5a78efdc56ecd0951e35ca60db175650232"
|
SRCREV = "d649e5a78efdc56ecd0951e35ca60db175650232"
|
||||||
|
|
||||||
SRC_URI = "git://github.com/fifteenhex/xradio.git;protocol=https \
|
SRC_URI = "git://github.com/fifteenhex/xradio.git;protocol=https \
|
||||||
file://Add_Targets_To_Makefile.patch \
|
|
||||||
"
|
"
|
||||||
|
|
||||||
S = "${WORKDIR}/git"
|
S = "${WORKDIR}/git"
|
||||||
|
|
||||||
|
EXTRA_OEMAKE += "-C ${STAGING_KERNEL_DIR} M=${S}"
|
||||||
|
|
||||||
KERNEL_MODULE_AUTOLOAD += "xradio_wlan"
|
KERNEL_MODULE_AUTOLOAD += "xradio_wlan"
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index fd15d31..078a2ad 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -50,3 +50,14 @@ ccflags-y += -DXRADIO_USE_LONG_KEEP_ALIVE_PERIOD
|
|
||||||
ldflags-y += --strip-debug
|
|
||||||
|
|
||||||
obj-$(CONFIG_XRADIO) += xradio_wlan.o
|
|
||||||
+
|
|
||||||
+SRC := $(shell pwd)
|
|
||||||
+
|
|
||||||
+all:
|
|
||||||
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
|
|
||||||
+
|
|
||||||
+modules_install:
|
|
||||||
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
|
|
||||||
+
|
|
||||||
+clean:
|
|
||||||
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
|
|
Loading…
Reference in New Issue
Block a user