mirror of
https://github.com/linux-sunxi/meta-sunxi.git
synced 2024-11-10 15:28:22 +01:00
recipes-kernel: xradio: Added wifi driver for orange-pi-zero wifi
Driver taken from: https://github.com/Halolo/orange-pi-distro.git Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
This commit is contained in:
parent
712229cbe4
commit
318e609f65
22
recipes-kernel/xradio/xradio.bb
Normal file
22
recipes-kernel/xradio/xradio.bb
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
SUMMARY = "Xradio WiFi driver for orangepi-zero"
|
||||||
|
LICENSE = "GPLv2"
|
||||||
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=a23a74b3f4caf9616230789d94217acb"
|
||||||
|
|
||||||
|
inherit module
|
||||||
|
|
||||||
|
PV = "0.1"
|
||||||
|
PR = "r0"
|
||||||
|
|
||||||
|
RDEPENDS_${PN} += "xradio-firmware"
|
||||||
|
|
||||||
|
COMPATIBLE_MACHINE = "orange-pi-zero"
|
||||||
|
|
||||||
|
SRCREV = "d649e5a78efdc56ecd0951e35ca60db175650232"
|
||||||
|
|
||||||
|
SRC_URI = "git://github.com/fifteenhex/xradio.git;protocol=https \
|
||||||
|
file://Add_Targets_To_Makefile.patch \
|
||||||
|
"
|
||||||
|
|
||||||
|
S = "${WORKDIR}/git"
|
||||||
|
|
||||||
|
KERNEL_MODULE_AUTOLOAD += "xradio_wlan"
|
19
recipes-kernel/xradio/xradio/Add_Targets_To_Makefile.patch
Normal file
19
recipes-kernel/xradio/xradio/Add_Targets_To_Makefile.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index fd15d31..078a2ad 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -50,3 +50,14 @@ ccflags-y += -DXRADIO_USE_LONG_KEEP_ALIVE_PERIOD
|
||||||
|
ldflags-y += --strip-debug
|
||||||
|
|
||||||
|
obj-$(CONFIG_XRADIO) += xradio_wlan.o
|
||||||
|
+
|
||||||
|
+SRC := $(shell pwd)
|
||||||
|
+
|
||||||
|
+all:
|
||||||
|
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
|
||||||
|
+
|
||||||
|
+modules_install:
|
||||||
|
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
|
||||||
|
+
|
||||||
|
+clean:
|
||||||
|
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
|
Loading…
Reference in New Issue
Block a user