mirror of
https://github.com/linux-sunxi/meta-sunxi.git
synced 2024-11-08 06:18:22 +01:00
allwinner-a10: initial import.
Signed-off-by: Enrico Butera <ebutera@users.berlios.de>
This commit is contained in:
parent
770eab6338
commit
0192226c66
17
COPYING.MIT
Normal file
17
COPYING.MIT
Normal file
@ -0,0 +1,17 @@
|
||||
Permission is hereby granted, free of charge, to any person obtaining a copy
|
||||
of this software and associated documentation files (the "Software"), to deal
|
||||
in the Software without restriction, including without limitation the rights
|
||||
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
|
||||
copies of the Software, and to permit persons to whom the Software is
|
||||
furnished to do so, subject to the following conditions:
|
||||
|
||||
The above copyright notice and this permission notice shall be included in
|
||||
all copies or substantial portions of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
|
||||
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
|
||||
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
|
||||
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
|
||||
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
||||
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
|
||||
THE SOFTWARE.
|
@ -2,3 +2,11 @@ meta-allwinner
|
||||
==============
|
||||
|
||||
UNOFFICIAL OE-core layer for Allwinner A10 boards
|
||||
|
||||
Author: Enrico Butera <ebutera@users.berlios.de>
|
||||
|
||||
This layer depends on the additional layer:
|
||||
|
||||
meta-openembedded: git://git.openembedded.org/meta-openembedded
|
||||
|
||||
Build tested with core-image-base.
|
||||
|
9
conf/layer.conf
Normal file
9
conf/layer.conf
Normal file
@ -0,0 +1,9 @@
|
||||
# We have a conf and classes directory, append to BBPATH
|
||||
BBPATH .= ":${LAYERDIR}"
|
||||
|
||||
# We have a recipes directory, add to BBFILES
|
||||
BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
|
||||
|
||||
BBFILE_COLLECTIONS += "meta-allwinner"
|
||||
BBFILE_PATTERN_meta-allwinner := "^${LAYERDIR}/"
|
||||
BBFILE_PRIORITY_meta-allwinner = "10"
|
29
conf/machine/allwinner-a10.conf
Normal file
29
conf/machine/allwinner-a10.conf
Normal file
@ -0,0 +1,29 @@
|
||||
#@TYPE: Machine
|
||||
#@NAME: Allwinner A10 machine
|
||||
#@DESCRIPTION: Machine configuration for the Allwinner A10 boards
|
||||
|
||||
PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
|
||||
XSERVER = "xserver-xorg \
|
||||
xf86-input-evdev \
|
||||
xf86-input-mouse \
|
||||
xf86-input-keyboard"
|
||||
|
||||
# Only has DVI connector for external screen
|
||||
GUI_MACHINE_CLASS = "bigscreen"
|
||||
|
||||
require conf/machine/include/tune-cortexa8.inc
|
||||
|
||||
PREFERRED_PROVIDER_virtual/kernel = "linux-allwinner"
|
||||
|
||||
KERNEL_IMAGETYPE = "uImage"
|
||||
|
||||
UBOOT_MACHINE = "sun4i"
|
||||
|
||||
IMAGE_FSTYPES += "tar.bz2"
|
||||
|
||||
# Guesswork
|
||||
SERIAL_CONSOLE = "115200 ttyS2"
|
||||
|
||||
#EXTRA_IMAGECMD_jffs2 = "-lnp -e 0x40000 -s 4096"
|
||||
|
||||
MACHINE_FEATURES = "kernel26 screen apm usbgadget usbhost vfat alsa"
|
19
recipes-bsp/u-boot/u-boot_git.bb
Normal file
19
recipes-bsp/u-boot/u-boot_git.bb
Normal file
@ -0,0 +1,19 @@
|
||||
require recipes-bsp/u-boot/u-boot.inc
|
||||
|
||||
LICENSE = "GPL"
|
||||
|
||||
# No patches for other machines yet
|
||||
COMPATIBLE_MACHINE = "allwinner-a10"
|
||||
|
||||
DEFAULT_PREFERENCE_allwinner-a10 = "1"
|
||||
|
||||
SRC_URI = "git://github.com/hno/uboot-allwinner.git;protocol=git;branch=sun4i \
|
||||
"
|
||||
|
||||
# 2012/05/31: Rename spl loader to sun4i-spl.bin for now
|
||||
SRCREV = "e5eb03e7cd61ebcf552f6c809783d025786cdb24"
|
||||
PR = "r1"
|
||||
|
||||
LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
|
||||
|
||||
S = "${WORKDIR}/git"
|
1934
recipes-kernel/linux/linux-allwinner-git/allwinner-a10/defconfig
Normal file
1934
recipes-kernel/linux/linux-allwinner-git/allwinner-a10/defconfig
Normal file
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,31 @@
|
||||
diff --git a/drivers/media/video/sun4i_csi/include/sun4i_csi_core.h b/drivers/media/video/sun4i_csi/include/sun4i_csi_core.h
|
||||
index 010814d..9e0e5f2 100755
|
||||
--- a/drivers/media/video/sun4i_csi/include/sun4i_csi_core.h
|
||||
+++ b/drivers/media/video/sun4i_csi/include/sun4i_csi_core.h
|
||||
@@ -357,12 +357,12 @@ struct csi_dev {
|
||||
void bsp_csi_open(struct csi_dev *dev);
|
||||
void bsp_csi_close(struct csi_dev *dev);
|
||||
void bsp_csi_configure(struct csi_dev *dev,__csi_conf_t *mode);
|
||||
-void inline bsp_csi_set_buffer_address(struct csi_dev *dev,__csi_buf_t buf, u32 addr);
|
||||
-u32 inline bsp_csi_get_buffer_address(struct csi_dev *dev,__csi_buf_t buf);
|
||||
+void bsp_csi_set_buffer_address(struct csi_dev *dev,__csi_buf_t buf, u32 addr);
|
||||
+u32 bsp_csi_get_buffer_address(struct csi_dev *dev,__csi_buf_t buf);
|
||||
void bsp_csi_double_buffer_enable(struct csi_dev *dev);
|
||||
void bsp_csi_double_buffer_disable(struct csi_dev *dev);
|
||||
-void inline bsp_csi_double_buffer_select_next(struct csi_dev *dev,__csi_double_buf_t type);
|
||||
-void inline bsp_csi_double_buffer_get_status(struct csi_dev *dev,__csi_double_buf_status_t * status);
|
||||
+void bsp_csi_double_buffer_select_next(struct csi_dev *dev,__csi_double_buf_t type);
|
||||
+void bsp_csi_double_buffer_get_status(struct csi_dev *dev,__csi_double_buf_status_t * status);
|
||||
void bsp_csi_capture_video_start(struct csi_dev *dev);
|
||||
void bsp_csi_capture_video_stop(struct csi_dev *dev);
|
||||
void bsp_csi_capture_picture(struct csi_dev *dev);
|
||||
@@ -371,7 +371,7 @@ void bsp_csi_set_size(struct csi_dev *dev, u32 length_h, u32 length_v, u32 buf_
|
||||
void bsp_csi_set_offset(struct csi_dev *dev,u32 start_h, u32 start_v);
|
||||
void bsp_csi_int_enable(struct csi_dev *dev,__csi_int_t interrupt);
|
||||
void bsp_csi_int_disable(struct csi_dev *dev,__csi_int_t interrupt);
|
||||
-void inline bsp_csi_int_get_status(struct csi_dev *dev,__csi_int_status_t * status);
|
||||
-void inline bsp_csi_int_clear_status(struct csi_dev *dev,__csi_int_t interrupt);
|
||||
+void bsp_csi_int_get_status(struct csi_dev *dev,__csi_int_status_t * status);
|
||||
+void bsp_csi_int_clear_status(struct csi_dev *dev,__csi_int_t interrupt);
|
||||
|
||||
#endif /* _CSI_H_ */
|
24
recipes-kernel/linux/linux-allwinner_git.bb
Normal file
24
recipes-kernel/linux/linux-allwinner_git.bb
Normal file
@ -0,0 +1,24 @@
|
||||
require recipes-kernel/linux/linux.inc
|
||||
|
||||
COMPATIBLE_MACHINE = "allwinner-a10"
|
||||
|
||||
DESCRIPTION = "Linux kernel for Allwinner A10 boards"
|
||||
KERNEL_IMAGETYPE = "uImage"
|
||||
|
||||
#DEFAULT_PREFERENCE = "-99"
|
||||
|
||||
PV = "3.0.8+"
|
||||
SRCREV_pn-${PN} = "5080a650d1c91e6da2f29d4480bbf7e44b08cfad"
|
||||
|
||||
FILESEXTRAPATHS := "${THISDIR}/${PN}-git"
|
||||
|
||||
# The main PR is now using MACHINE_KERNEL_PR
|
||||
MACHINE_KERNEL_PR_append = "a"
|
||||
|
||||
SRC_URI += "git://github.com/amery/linux-allwinner.git;protocol=git;branch=lichee-3.0.8-sun4i \
|
||||
\
|
||||
file://csi/3.0.8-fix-csi-inline.patch \
|
||||
file://defconfig"
|
||||
|
||||
S = "${WORKDIR}/git"
|
||||
|
Loading…
Reference in New Issue
Block a user