mirror of
https://github.com/lxsang/meta-rpi-diya.git
synced 2024-11-08 14:38:21 +01:00
9 lines
410 B
Plaintext
9 lines
410 B
Plaintext
do_install:append() {
|
|
# grant all permission to sudo group
|
|
sed -i 's/^#\s*\(%sudo\s*ALL=(ALL:ALL)\s*ALL\)/\1/' ${D}/${sysconfdir}/sudoers
|
|
# allow sudo group to power off/reboot system without password
|
|
cat << EOF >> ${D}/${sysconfdir}/sudoers
|
|
## sudo user group is allowed to execute halt and reboot
|
|
%sudo ALL=NOPASSWD: /sbin/halt, /sbin/reboot, /sbin/poweroff, /usr/bin/swaylock
|
|
EOF
|
|
} |