diff --git a/recipes-support/sfwbar/files/icon.svg b/recipes-support/sfwbar/files/icon.svg
deleted file mode 100644
index e4601fa..0000000
--- a/recipes-support/sfwbar/files/icon.svg
+++ /dev/null
@@ -1,7 +0,0 @@
-
-
-
\ No newline at end of file
diff --git a/recipes-support/sfwbar/files/sfwbar.config b/recipes-support/sfwbar/files/sfwbar.config
index 6b93f44..6f6976d 100644
--- a/recipes-support/sfwbar/files/sfwbar.config
+++ b/recipes-support/sfwbar/files/sfwbar.config
@@ -83,12 +83,12 @@ menu("winops") {
layout {
button {
style = "launcher"
- value = "/usr/share/icons/hicolor/scalable/apps/tofi.svg"
+ value = "/usr/share/icons/Adwaita/scalable/actions/view-app-grid-symbolic.svg"
tooltip = "Quick menu"
action = Exec "bash -c \"`tofi-drun`\""
}
button {
- value = "/usr/share/icons/hicolor/scalable/actions/show-desktop.svg"
+ value = "/usr/share/icons/Adwaita/scalable/devices/tv-symbolic.svg"
style = "launcher"
tooltip = "Show Desktop"
action = Function "target", "ShowDesktop"
@@ -123,14 +123,16 @@ layout {
#CSS
button#launcher, button#module{
padding: 0px 2px 0px 2px;
- background: none;
- border-style:none;
+ /*background: none;
+ background-color: #5F548E;*/
+ border-style:none;
box-shadow: none;
+ border-radius: 0;
}
window {
-GtkWidget-direction: top;
- background-color: rgba(0,0,0,0.6);
+ /*background-color: rgba(0,0,0,0.6);*/
border-color: rgba(0,0,0,0.3);
}
@@ -143,7 +145,6 @@ button#taskbar_normal grid {
padding-right: 0px;
margin-right: 0px;
}
-
button#launcher image, button#taskbar_normal image, button#taskbar_active image, button#taskbar_normal:hover image {
-GtkWidget-vexpand: true;
box-shadow: none;
@@ -180,14 +181,21 @@ button#taskbar_normal , button#taskbar_active , button#taskbar_normal:hover {
box-shadow: none;
}
+button#taskbar_normal label {
+ color: black;
+}
+
button#taskbar_active {
/* background-color: rgba(255,255,255,0.2);
border-color: rgba(255,255,255,0.4); */
- border-bottom:3px solid #116cd6;
+ border-bottom:3px solid #5F548E;
+}
+button#taskbar_active label, button#taskbar_normal:hover label {
+ color: #5F548E;
}
/* button#taskbar_active:hover*/
button#taskbar_normal:hover {
- background-color: rgba(176,176,176,0.22);
+ background-color: #d2d2d2;
border-color: rgba(234,234,234,0.44);
}
diff --git a/recipes-support/sfwbar/sfwbar_git.bb b/recipes-support/sfwbar/sfwbar_git.bb
index a32ef85..e480f9f 100644
--- a/recipes-support/sfwbar/sfwbar_git.bb
+++ b/recipes-support/sfwbar/sfwbar_git.bb
@@ -10,7 +10,7 @@ DEPENDS = "gtk+3 gtk-layer-shell json-c wayland-native"
SRCREV = "${AUTOREV}"
SRC_URI = "git://github.com/LBCrion/sfwbar.git;protocol=https;branch=main"
-SRC_URI += " file://sfwbar.config file://icon.svg "
+SRC_URI += " file://sfwbar.config "
S="${WORKDIR}/git"
@@ -21,13 +21,6 @@ EXTRA_OEMESON += "--buildtype release"
do_install:append () {
install -d ${D}/${sysconfdir}/sfwbar/
install -m 0755 ${WORKDIR}/sfwbar.config ${D}/${sysconfdir}/sfwbar/
-
- install -d ${D}/usr/share
- install -d ${D}/usr/share/icons
- install -d ${D}/usr/share/icons/hicolor
- install -d ${D}/usr/share/icons/hicolor/scalable
- install -d ${D}/usr/share/icons/hicolor/scalable/actions/
- install -m 0755 ${WORKDIR}/icon.svg ${D}/usr/share/icons/hicolor/scalable/actions/show-desktop.svg
}
FILES:${PN} += "/usr/share/icons/*"
\ No newline at end of file
diff --git a/recipes-support/tofi/files/icon.svg b/recipes-support/tofi/files/icon.svg
deleted file mode 100644
index 0a3cd43..0000000
--- a/recipes-support/tofi/files/icon.svg
+++ /dev/null
@@ -1,2 +0,0 @@
-
-
\ No newline at end of file
diff --git a/recipes-support/tofi/tofi_git.bb b/recipes-support/tofi/tofi_git.bb
index 7a9cc62..f257de2 100644
--- a/recipes-support/tofi/tofi_git.bb
+++ b/recipes-support/tofi/tofi_git.bb
@@ -10,7 +10,7 @@ DEPENDS = "wayland freetype wayland-native wayland-protocols-native wayland-prot
SRCREV = "${AUTOREV}"
SRC_URI = "git://github.com/philj56/tofi.git;protocol=https;branch=master"
-SRC_URI += " file://icon.svg file://config "
+SRC_URI += " file://config "
S="${WORKDIR}/git"
@@ -19,13 +19,6 @@ inherit meson pkgconfig
EXTRA_OEMESON += "--buildtype release"
do_install:append () {
- install -d ${D}/usr/share
- install -d ${D}/usr/share/icons
- install -d ${D}/usr/share/icons/hicolor
- install -d ${D}/usr/share/icons/hicolor/scalable
- install -d ${D}/usr/share/icons/hicolor/scalable/apps
- install -m 0755 ${WORKDIR}/icon.svg ${D}/usr/share/icons/hicolor/scalable/apps/tofi.svg
-
# replace the default config
install -m 0755 ${WORKDIR}/config ${D}/${sysconfdir}/xdg/tofi/
}
diff --git a/recipes-wlroots/labwc/files/init b/recipes-wlroots/labwc/files/init
index ce28884..d30e0af 100755
--- a/recipes-wlroots/labwc/files/init
+++ b/recipes-wlroots/labwc/files/init
@@ -35,7 +35,7 @@ case "$1" in
;;
stop)
- echo "Stopping Weston"
+ echo "Stopping labwc"
killproc labwc
;;